Bug 748414 - Non-fatal POSTIN scriptlet failure in rpm package 2:qemu-common-0.15.1-1.fc16.x86_64
Non-fatal POSTIN scriptlet failure in rpm package 2:qemu-common-0.15.1-1.fc16...
Status: CLOSED DUPLICATE of bug 748281
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 08:06 EDT by Richard W.M. Jones
Modified: 2013-01-09 06:55 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 11:33:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2011-10-24 08:06:17 EDT
Description of problem:

[...]
  Updating   : 2:qemu-common-0.15.1-1.fc16.x86_64                    1/18 
Non-fatal POSTIN scriptlet failure in rpm package 2:qemu-common-0.15.1-1.fc16.x86_64
Operation failed: No such file or directory
Operation failed: No such file or directory
warning: %post(qemu-common-2:0.15.1-1.fc16.x86_64) scriptlet failed, exit status 1
  Updating   : 2:qemu-system-x86-0.15.1-1.fc16.x86_64                2/18 
[...]

This also appears to cause the later cleanup on qemu-common
to fail (hangs on a futex).

Version-Release number of selected component (if applicable):

2:0.15.1

How reproducible:

I only tried it once.

Steps to Reproduce:
1. yum update qemu (old version was 2:qemu-common-0.15.0-5.fc16.x86_64)
2.
3.
  
Actual results:

%postin script fails as above.

Expected results:

Should not fail.

Additional info:

Here is the script ...

getent group kvm >/dev/null || groupadd -g 36 -r kvm
getent group qemu >/dev/null || groupadd -g 107 -r qemu
getent passwd qemu >/dev/null || \
  useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
    -c "qemu user" qemu

/bin/systemctl --global enable ksm.service
/bin/systemctl --global enable ksmtuned.service

The errors appear to come from the systemctl commands at the
end.  Is this a systemd error?

$ rpm -q systemd
systemd-35-1.fc16.x86_64
Comment 1 Richard W.M. Jones 2011-10-24 08:07:44 EDT
Updated to systemd 37, but same error:

$ sudo /bin/systemctl --global enable ksm.service
Operation failed: No such file or directory
Comment 2 Justin M. Forbes 2011-10-24 11:33:08 EDT

*** This bug has been marked as a duplicate of bug 748281 ***

Note You need to log in before you can comment on or make changes to this bug.