Bug 74847 - Unhandled exception has occurred
Unhandled exception has occurred
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 00:41 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-02 00:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-02 00:41:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)

Description of problem:
Once the Installing Packages Phase of the installation is hit (but before 
anything is installed) an unhandled exception occurrs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run RedHat Install-CD (Graphical or Text mode)
2.Complete Information gathering screens
3. **See Results ***
	

Actual Results:  Once the Installing Packages Phase of the installation is hit 
(but before anything is installed) an unhandled exception occurrs.  The system 
indicates I should save dump to floppy but 'Save to floppy' has no effect.  I 
will try to type a little of the dump:

Traceback(most recent call lst):
File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback 
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/gui.py", line 149, in RenderCallback 
self.intf.icw.nextClicked()

... similar messages ... then ...

File "/usr/lib/anaconda/gui.py", line 66, in execWithRedirect
 childpid = os.fork()
OSError:[Errno 12]Cannot allocate memory


Expected Results:  Installs

Additional info:

Tried various Graphical and Text installs.

System: P3; 600MZ; 64MB memory; Video: Intel 810
Comment 1 Need Real Name 2002-10-02 00:45:36 EDT
Note: This system had been running RedHat Linux 7.1 without issues.  The 7.1 
install was removed and this was a fresh 8.0 install.
Comment 2 Need Real Name 2002-10-02 01:33:36 EDT
Can't duplicate again under text-based install although initial attempt at text-
based install failed.  Not sure why initial text-based install failed due to 
memory allocation.  Graphical failure is due to excessive memory requirement.
Comment 3 Michael Lee Yohe 2003-01-09 09:09:53 EST
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M+ of memory and 128M of
swap.  

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.  Anaconda, in
text mode, is more lenient on memory resources.

Note You need to log in before you can comment on or make changes to this bug.