Bug 76123 - installer hangs with traceback error (OS Error:[Errno 12] Cannot allocate memory
installer hangs with traceback error (OS Error:[Errno 12] Cannot allocate memory
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: 77598 78719 78756 82047 82164 82452 82881 83067 84130 85067 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-10-17 02:07 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-24 15:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-17 02:07:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
Version 7.3 installed fine with same hardware but not 8.0. Goes through whole 
intallation setup including hard drive partitioning and install packages and 
dependancies but then halts with traceback report. System is Gateway 2000 P5-
120 with STB Trio 64 video card (S3) and Vivitron 1572 (Sony) monitor. Disk 
drives are WD 5.1GB (Linux) and WD 1.6GB (Windows 98)dual booting. Doing 
install of workstation

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1./boot 100mb
2./      4.9Gb
3./swap 100mb

Actual Results:  get Traceback error everytime:

Traceback (most recent call last):

file "/usr/anaconda/gui.py", line 786 in handleRenderCallback
file "/usr/lib/anaconda/iw/progress_gui.py", line 149, in 

file "/usr/lib/anaconda/gui.py", line 632, in nextClickedself.dispatch.gotonext
file "/usr/lib/anaconda/dispatch.py", line 150, in gotoNextself.movestep()
file "/usr/lib/anaconda/dispatch.py", line 215 in moveStep
file "/usr/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetadeletes (diskset)
file "/usr/lib/anaconda/partions.py", line 1110, in doMetaDeletes
file "/usr/lib/anaconda/lvm.py", line 54 in vgactivate
  searchPath=1)  ** note single bracket **
file "/usr/lib/anaconda/iutil.py", line 66, in execwithRedirect
OSError: [Errno 12] Cannot allocate memory

Expected Results:  should have proceeded to format the partitions and then 
start install of packages.

Additional info:

using boot.img to boot from floppy disk to CDROM. Tried image from 8.0 
distribution and also from 7.3. Two drive are HDA (windows 98) and HDB for 
Linux. Installation works fine for 7.3. Tried both ext2 and ext3 partitions. 
Suspect either a formating problem of HD or video problem. Using Personal 
package just bought and received (not ISO downloads.
Comment 1 Jeremy Katz 2002-10-18 11:44:48 EDT
How much memory do you have in your machine?
Comment 2 Need Real Name 2002-10-18 13:06:27 EDT
There is 64mb of memory in system
Comment 3 Need Real Name 2002-10-21 15:58:36 EDT
the system has 64 mb.
Comment 4 Akurathi Krishna 2002-10-21 23:30:01 EDT
I am also ruuning into same problem. I am booting the system using MS-DOS disk 
and ending with the above error. I changed few options and the problem is always
showing up. I did not test with Linux7.2. This problem is Linux Installer8.0.
Comment 5 Alejandro Ron 2002-10-23 12:41:30 EDT
I have the same ploblem. My PC is a IBM NetVista 6269-R3S, Intel Pentium III 
600MHz, 64 Ram, HD 13GB IBM, Video Intel 810, Monitor IBM G42.

I don't have any partition on the HD. I'm using RedHat Linux 8.0
Comment 6 Alejandro Ron 2002-10-23 12:47:04 EDT
The program also told me that my HD have an inconsistent geometry and 
recommends me to use LBA. And that this could not affect the use of it.
Comment 7 pladab 2002-10-24 03:50:39 EDT
i have met the same error problem.
please told me how i can fix it.
Comment 8 Arnaud LEBEC 2002-10-24 08:39:24 EDT
I get the same problem when i try to install 8.0 on my Toshiba Laptop.

I couldn't install 7.3 on this machine (it booted from diskette, caught signal
11 in /sbin/loader), so i tried to install 8.0.

8.0 lets me do all parametering, until i finally launch the installation, and
then getting the tracaback error, without possibility to save it to a floppy
(doesn't work...).

Does anyone know how to fix that ?
Comment 9 Need Real Name 2002-10-24 10:18:14 EDT
I've got a Pentium 166 w/64MB memory - 1GB, 3GB, 6GB IDE hard drives - I get 
this on floppy/CD install of Linux 8.0:

File "usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc = apply(func, self.bindArgs(args))
File "usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
File "usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
File "usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath = 1)
File "usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno 12] Cannot allocate memory

install exited normally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
	/mnt/runtime done
	disabling /dev/loop0
	/proc done
	/dev/pts done
	/mnt/source done
you may safely reboot your system
Comment 10 Jeremy Katz 2002-10-24 15:12:47 EDT
Going back in graphical mode with only 64 megs of ram seems to exhaust available
memory.  Please boot with 'linux text' and do a text mode install or go forward
through the install process.  I've bumped the numbers in CVS for turning on swap
Comment 11 Need Real Name 2002-11-15 19:34:42 EST
I do have an Dell Pentium III, with 128mb and I am getting the same annoying 
message and the installation quits. It does not happens with 7.2 and 7.3. 
Should be a bug. Is there any other solution, rather than installing using the 
text only facility ?
Comment 12 Need Real Name 2002-11-15 19:38:15 EST
I would like to appologize for my last message. My computer does have only 64mb 
and NOT 128Mb as I wrote. So probably I am having the same memory problem. But 
anyway the installation program should work fine with 64Mb like the earlier 
Comment 13 Need Real Name 2002-11-19 15:44:28 EST
I have a Pentium 133 mhz with 40 MB memory installed and I'm having the same 
problem. Can I work with version 7.3 in graphical mode with this amount of 
memory? Can somebody give the answer to this question?
Comment 14 Andreas Griesser 2002-12-01 15:02:59 EST
I too got this traceback error with Redhat 8.0 booting from floppy and 
installing from the ftp site.

I have a P4 2,67 GHz, 512MB RDRAM, 80GB HDD partitioned with 100MB /boot, 1GB 
swap, 10GB /, 60GB /workpartition. Except of swap the filesystem is ext3.

The installation reports an error reading the partition table from this 
Comment 15 Need Real Name 2002-12-11 08:01:56 EST
I had same problem installing RH 8.0. Had 64mb RAM and adding 128mb goes fine, 
i finished instalation with anaconda ok !! :)
Anyone have other less expensive solution??
Comment 16 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 17 Jeremy Katz 2003-01-10 01:55:32 EST
*** Bug 78756 has been marked as a duplicate of this bug. ***
Comment 18 Jeremy Katz 2003-01-11 01:55:36 EST
*** Bug 78719 has been marked as a duplicate of this bug. ***
Comment 19 Need Real Name 2003-01-21 09:50:51 EST
*** Bug 82047 has been marked as a duplicate of this bug. ***
Comment 20 Jeremy Katz 2003-01-22 01:02:03 EST
*** Bug 82164 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2003-01-29 16:44:24 EST
*** Bug 82881 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2003-01-29 17:01:28 EST
*** Bug 82452 has been marked as a duplicate of this bug. ***
Comment 23 Greg Hinds 2003-01-29 23:23:05 EST
Why was this closed?
Comment 24 Matt Evett 2003-02-06 16:44:47 EST
*** Bug 83067 has been marked as a duplicate of this bug. ***
Comment 25 Jeremy Katz 2003-02-07 15:47:47 EST
*** Bug 77598 has been marked as a duplicate of this bug. ***
Comment 26 Jeremy Katz 2003-02-14 12:26:13 EST
*** Bug 84130 has been marked as a duplicate of this bug. ***
Comment 27 Need Real Name 2003-03-03 11:08:27 EST
Is there a workaround or fix that can be downloaded to get allow installs on 
machines with 64M?
Comment 28 Michael Fulbright 2003-04-22 12:18:25 EDT
*** Bug 85067 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.