Bug 748488 - Anaconda fails to offer correct grub install device
Anaconda fails to offer correct grub install device
Status: CLOSED DUPLICATE of bug 744088
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-24 11:26 EDT by Jes Sorensen
Modified: 2011-10-24 11:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 11:41:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
storage.log (495.55 KB, text/plain)
2011-10-24 11:29 EDT, Jes Sorensen
no flags Details

  None (edit)
Description Jes Sorensen 2011-10-24 11:26:49 EDT
Description of problem:
Trying to install F16 Beta TC1 on a system with a mix of BIOS raid and
regular hard drives, anaconda fails to let me install grub on the correct
mbr.

Version-Release number of selected component (if applicable):
Fedora-16-Beta-TC1

How reproducible:
Every time

Steps to Reproduce:
My setup is as follows:
4 x 500GB SATA drives
/dev/sd[ab] are assembled as a raid container with two raids
 (/dev/md125 and /dev/md126)
/dev/sd[cd] are left as standalone drives

Fedora-16-Beta-TC1 iso put onto a USB stick using livecd-iso-to-disk

I create two regular partitions on /dev/md126 for boot and /, format them
etc. Once it gets to the grub install section, I wish to install grub
on /dev/md126. However anaconda is only offering me to put it on the
mbr of /dev/sdc, or boot partition /dev/md126p1.

In previous releases I were able to fiddle with the BIOS boot order
settings to get anaconda to offer me the right device for the mbr
install.

Installing on the boot partition is not an option as it won't boot off
that for whatever reason. One needs to be able to select which device's
mbr to install grub on.

This bug makes it impossible to install a bootable F16 on this setup :(
  
Actual results:


Expected results:


Additional info:
Comment 3 Jes Sorensen 2011-10-24 11:29:36 EDT
Created attachment 529905 [details]
storage.log
Comment 5 David Lehman 2011-10-24 11:41:51 EDT

*** This bug has been marked as a duplicate of bug 744088 ***

Note You need to log in before you can comment on or make changes to this bug.