Bug 748841 - f15->f16 upgrade: cups is no longer enabled, printers have all disappeared
Summary: f15->f16 upgrade: cups is no longer enabled, printers have all disappeared
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 731421 744078 749788 752671 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-25 13:53 UTC by Need Real Name
Modified: 2011-11-16 00:27 UTC (History)
9 users (show)

Fixed In Version: cups-1.5.0-22.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-16 00:27:15 UTC


Attachments (Terms of Use)

Description Need Real Name 2011-10-25 13:53:41 UTC
Description of problem:
After upgrading to F16 I can no longer see any of my printers since cups has been disabled. I must manually re-enable cups using the cli. I have no idea how a gui user could do this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tim Waugh 2011-10-25 14:10:03 UTC
Unfortunately this is a manual step:

https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Packages_migrating_to_a_systemd_unit_file_from_a_SysV_initscript

Use "systemd-sysv-convert --apply" to do this.

Comment 2 Tim Waugh 2011-10-31 10:53:28 UTC
*** Bug 749788 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2011-10-31 10:54:13 UTC
Oh, it turns out there was a line missing from the upgrade trigger.

Comment 4 Fedora Update System 2011-10-31 12:14:00 UTC
cups-1.5.0-19.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/cups-1.5.0-19.fc16

Comment 5 Fedora Update System 2011-11-01 01:27:39 UTC
Package cups-1.5.0-19.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.0-19.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15223
then log in and leave karma (feedback).

Comment 6 Tim Waugh 2011-11-04 10:12:28 UTC
*** Bug 731421 has been marked as a duplicate of this bug. ***

Comment 7 Tim Waugh 2011-11-07 16:39:06 UTC
*** Bug 744078 has been marked as a duplicate of this bug. ***

Comment 8 Tim Waugh 2011-11-09 17:02:32 UTC
I've added a trigger so that updates after upgrade re-enable the package.

In other words:

1. Upgrade from e.g. Fedora 15 to Fedora 16
2. Apply updates

To test it, please apply the update for cups-1.5.0-21.fc16 from updates-testing, and verify that cups.service is now enabled:

systemctl status cups.service

It should say:

	  Loaded: loaded (/lib/systemd/system/cups.service; enabled)

Comment 9 dario 2011-11-09 21:18:12 UTC
i uninstalled cups an when tying to re-install i get 

Protected multilib versions: gutenprint-5.2.7-4.fc16.i686 != gutenprint-5.2.7-7.fc16.x86_64

Comment 10 Antonio 2011-11-10 16:09:30 UTC
>To test it, please apply the update for cups-1.5.0-21.fc16 from
>updates-testing, and verify that cups.service is now enabled

cups-1.5.0-21.fc16 version seems work.
After installation:

# systemctl enable cups.service
# systemctl start cups.service
# reboot

Comment 11 Tim Waugh 2011-11-10 17:32:52 UTC
(In reply to comment #10)
> # systemctl enable cups.service

The update should already have done this step -- you don't need to do it manually.

Comment 12 Tim Waugh 2011-11-10 17:43:39 UTC
*** Bug 752671 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2011-11-10 17:51:29 UTC
Package cups-1.5.0-21.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.0-21.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15223
then log in and leave karma (feedback).

Comment 14 Tim Waugh 2011-11-11 13:55:00 UTC
Sorry, cups-1.5.0-21.fc16 had a mistake in the trigger.  New package to fix it: cups-1.5.0-22.fc16.

Comment 15 dario 2011-11-11 15:04:31 UTC
super fixed

Comment 16 Fedora Update System 2011-11-12 03:24:43 UTC
Package cups-1.5.0-22.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-1.5.0-22.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15223
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2011-11-16 00:27:15 UTC
cups-1.5.0-22.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.