Bug 748936 - QML demos (and most other things using QtDeclarative) are crashing
QML demos (and most other things using QtDeclarative) are crashing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 749015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 11:51 EDT by Slawomir Czarko
Modified: 2013-10-04 08:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: qt-4.7.4-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-14 17:27:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Qt Creator backtrace by Slawomir Czarko (24.64 KB, text/plain)
2011-10-26 08:11 EDT, Kevin Kofler
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-18906 None None None Never
Qt Bug Tracker QTBUG-19736 None None None Never

  None (edit)
Description Slawomir Czarko 2011-10-25 11:51:40 EDT
Description of problem:

I'm trying to run QML demos from qt-demos in /usr/lib/qt4/demos/declarative/

Some of them run but many fail with segmentation fault.


The demos which fail:
/usr/lib/qt4/demos/declarative/calculator/
/usr/lib/qt4/demos/declarative/photoviewer/
/usr/lib/qt4/demos/declarative/rssnews/
/usr/lib/qt4/demos/declarative/twitter/
/usr/lib/qt4/demos/declarative/webbrowser/

Most crash during initialization.

photoviewer crashes a few seconds after showing main window.
twitter crashes when "search" button is pressed


Version-Release number of selected component (if applicable):

qt-demos-4.7.4-2.fc15.i686


How reproducible:

100%

Steps to Reproduce:
1. Load one of the demos with qmlviewer or run it in Qt Creator
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2011-10-26 07:37:41 EDT
*** Bug 749015 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2011-10-26 07:47:20 EDT
Fwiw, all those referenced demos are ok on my f14/x86_64 box.
Comment 3 Kevin Kofler 2011-10-26 08:11:44 EDT
Created attachment 530276 [details]
Qt Creator backtrace by Slawomir Czarko

I extracted the backtrace of the relevant thread from:
https://bugzilla.redhat.com/show_bug.cgi?id=749015#c1

I can reproduce the crash in the calculator demo (not tested the others nor Qt Creator yet) with qt-x11-4.7.4-2.fc15.i686. The backtrace appears to match the Qt Creator one, but I haven't installed qt-x11-debuginfo yet, so there's a lot of information missing, and so I can't tell for sure.
Comment 4 Jaroslav Reznik 2011-11-03 12:17:01 EDT
Hit the same issue and I can confirm it's ok within Qt SDK (upstream Qt build) so it has to be something in our packaging or g++/whatever issue.
Comment 5 Kevin Kofler 2011-11-03 12:22:38 EDT
KAN EYE HAZ VALGRIND LOGZ PLZ LOL??????????!!!!!!!!?????????????

[insert picture of cute kitten here]

;-)
Comment 6 Jaroslav Reznik 2011-11-03 12:28:19 EDT
According to upstream's bug report (one of duplicates), -O2 -fno-strict-aliasing is working workaround.
Comment 7 Kevin Kofler 2011-11-03 12:30:40 EDT
Right, according to the upstream tracker, this is an aliasing issue.
Comment 8 Rex Dieter 2011-11-03 14:15:38 EDT
Found a couple of aliasing problems, once we looked closer,

%changelog
* Thu Nov 03 2011 Rex Dieter <rdieter@fedoraproject.org> 1:4.7.4-6
- build declarative/qml with -fno-strict-aliasing (#748936, QTBUG-19736)
- build tds sql driver with -fno-strict-aliasing

Build queue'd:
http://koji.fedoraproject.org/koji/buildinfo?buildID=272173
Comment 9 Fedora Update System 2011-11-04 09:59:53 EDT
qt-4.7.4-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/qt-4.7.4-6.fc15
Comment 10 Fedora Update System 2011-11-05 19:56:38 EDT
Package qt-4.7.4-6.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qt-4.7.4-6.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15480
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-11-14 17:27:13 EST
qt-4.7.4-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Red Hat Bugzilla 2013-10-03 20:21:37 EDT
Removing external tracker bug with the id '18906' as it is not valid for this tracker
Comment 13 Red Hat Bugzilla 2013-10-03 20:21:41 EDT
Removing external tracker bug with the id '19736' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.