Bug 749015 - qtcreator crashes when trying to open designer in Qt Quick project
qtcreator crashes when trying to open designer in Qt Quick project
Status: CLOSED DUPLICATE of bug 748936
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 16:22 EDT by Slawomir Czarko
Modified: 2011-10-26 07:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-26 07:37:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from thread 1 (24.64 KB, text/x-log)
2011-10-25 16:22 EDT, Slawomir Czarko
no flags Details
Backtrace from all threads (9.71 KB, application/x-bzip)
2011-10-25 16:24 EDT, Slawomir Czarko
no flags Details

  None (edit)
Description Slawomir Czarko 2011-10-25 16:22:46 EDT
Created attachment 530172 [details]
Backtrace from thread 1

Description of problem:



Version-Release number of selected component (if applicable):
qt-creator-2.2.1-2.fc15.i686

How reproducible:
100%

Steps to Reproduce:
1. In qtcreator open one of Qt Quick examples: /usr/lib/qt4/examples/declarative/touchinteraction/gestures/

2. When asked about copying the project to another location select either option, the crash happens in both cases
3. Click on experimental-gestures.qml in the file list
4. Click on Design in the list on the left
  
Actual results:


Expected results:


Additional info:

abrt doesn't get launched on this crash for some reason so I'll attach the backtrace manually
Comment 1 Slawomir Czarko 2011-10-25 16:24:09 EDT
Created attachment 530173 [details]
Backtrace from all threads
Comment 2 Slawomir Czarko 2011-10-26 06:14:50 EDT
This doesn't happen with qtcreator 2.3.1
http://qt.nokia.com/downloads/downloads#qt-creator
Comment 3 Kevin Kofler 2011-10-26 07:37:41 EDT
This is clearly the same Qt Declarative bug you encountered in the demos. It doesn't happen with the upstream Qt Creator binaries because they bundle their own Qt.

*** This bug has been marked as a duplicate of bug 748936 ***

Note You need to log in before you can comment on or make changes to this bug.