Bug 74895 - Firstboot is not graceful when RHN is being registered
Summary: Firstboot is not graceful when RHN is being registered
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 74724 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-02 17:08 UTC by Stephen John Smoogen
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 20:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen John Smoogen 2002-10-02 17:08:03 UTC
Description of Problem:

If during the firstboot, the RHN servers are not available then the user is left
in an awkward state. There is no feedback that anything/nothing is going on, and
if the sub-process dies... it seems to just come back asking if you want to
register or not.

How Reproducible:

Very

Steps to Reproduce:
1. install system and reboot
2. do the NTP etc.. but cause RHN not to be available somehow
3. watch the system sit there without any feedback.

Comment 1 Brent Fox 2002-10-14 20:56:30 UTC
Agreed.  This did not get much testing for various reasons.

Comment 2 Brent Fox 2002-10-14 21:03:02 UTC
*** Bug 74724 has been marked as a duplicate of this bug. ***

Comment 3 Stephen John Smoogen 2003-01-26 20:14:18 UTC
Tested in latest beta. Problem seems to have been fixed. Firstboot is also MUCH
more graceful when dealing with not being able to start X.

Kudos.

Comment 4 Brent Fox 2003-01-27 19:36:04 UTC
Thanks smooge.  Your help is invaluable and much appreciated.


Note You need to log in before you can comment on or make changes to this bug.