Bug 748964 - grub2-mkconfig does not work with an unpopulated GRUB_PREFIX (i.e. before grub2-install) if using a serial console
grub2-mkconfig does not work with an unpopulated GRUB_PREFIX (i.e. before gru...
Status: CLOSED DUPLICATE of bug 736993
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2011-10-25 13:50 EDT by Adam Williamson
Modified: 2012-03-09 13:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 13:35:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remove serial.mod check (1.01 KB, patch)
2012-03-08 16:49 EST, Brian Lane
no flags Details | Diff

  None (edit)
Description Adam Williamson 2011-10-25 13:50:29 EDT
This is a Rawhide 'clone' of https://bugzilla.redhat.com/show_bug.cgi?id=736993 to see if we can fix it better: an ugly hack is going into F16 anaconda to work around the bug for now.

grub2's /etc/grub.d/00_header has this code:

if [ "x$serial" = x1 ]; then
    if ! test -e ${GRUB_PREFIX}/serial.mod ; then
	echo "Serial terminal not available on this platform." >&2 ; exit 1
    fi

so if we're using a serial console and GRUB_PREFIX/serial.mod doesn't exist - which it won't, if grub2-install has never been run - mkconfig simply throws a hissy fit and exits. This means that anaconda bootloader installation fails in serial console installs as things stand, because grub2-mkconfig is run before grub2-install, as you'd think would make sense.

The ugly hack for F16 is to run grub2-install once before mkconfig and then again afterwards, but he thinks there should be a better 'real fix', hence this bug.
Comment 1 Brian Lane 2012-03-08 16:49:13 EST
Created attachment 568753 [details]
remove serial.mod check
Comment 2 Adam Williamson 2012-03-09 13:35:06 EST
736993 got re-opened for f17, so we can just consider this a real dupe now and follow up there.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 736993 ***

Note You need to log in before you can comment on or make changes to this bug.