Bug 74898 - Lock Screen does not work
Lock Screen does not work
Status: CLOSED DUPLICATE of bug 10715
Product: Red Hat Linux
Classification: Retired
Component: lockdev (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-10-02 13:36 EDT by Jeff Collins
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-21 20:33:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Collins 2002-10-02 13:36:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Lock Screen option does not work.  I click on the lock screen in the launcher
and nothing happens.  I've verified this on 3 other computers also.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Log in using Gnome
2.Click on the Redhat launcher
3.Click on lock screen

Actual Results:  Nothing happens

Expected Results:  The screen should lock, disallowing me to continue using it
unless I supply a password

Additional info:

I am using an IBM 390E Thinkpad laptop.  I have verified this bug on an A22m
thinkpad also.  By the way, this also was a problem in the NULL beta release of
Redhat 8.
Comment 1 Jeff Collins 2002-10-03 12:51:08 EDT
I think I've figured out why it doesn't work.  It's not working when I'm logged
in as root, because the Xscreensaver isn't running.  If I log in as another user
and click the lock screen option, the Xscreensaver screen pops up and asks me
for my password.  Should this work for users logged in as root?
Comment 2 David Balažic 2002-11-21 16:45:53 EST
It should. Or it should put up an explanation why it doesn't.
Comment 3 David Balažic 2002-11-21 19:53:08 EST
Here is what I get in .xsession-errors file :

Loaded background '0x8095f50
xscreensaver-command: no screensaver is running on display :0.0
Comment 4 Havoc Pennington 2002-11-21 20:32:56 EST
If you run xscreensaver as root it prints this:

xscreensaver: Can't open display: :0.0
xscreensaver: initial effective uid/gid was root/root (0/0)
xscreensaver: running as nobody/nobody (99/99)
xscreensaver: This is probably because you're logging in as root.  You
              shouldn't log in as root: you should log in as a normal user,
              and then `su' as needed.  If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.
              Please read the manual and FAQ for more information:

It *is* true that logging in as root is a pretty bad idea, though it's 
also true that you have to use the command line to avoid 
a root login sometimes (always a bug when you have to, IMO).
Comment 5 Bill Nottingham 2002-11-21 22:39:20 EST

*** This bug has been marked as a duplicate of 10715 ***

Note You need to log in before you can comment on or make changes to this bug.