Bug 10715 - xscreensaver does not work as root or lock virtual consoles
xscreensaver does not work as root or lock virtual consoles
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 11419 41108 54070 55442 74898 78370 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-10 22:36 EDT by whitis
Modified: 2014-03-16 22:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-11 10:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description whitis 2000-04-10 22:36:11 EDT
When you are running Xfree86 as root, xscreensaver does not work
for several reasons.  First, it sets its uid/gid to nobody and then
it can't access the screen; adding a xhost +nobody would be a very
bad idea.  It also has problems with the .xscreensaver file (according
to xscreensaver-demo) because it will read ~nobody/.xscreensaver but
xscreensaver-demo will modify ~root/.xscreensaver.

I don't normally run X as root but was doing so while initially
setting up a system.  Also, some of the redhat system management
tools are designed to be run as root.

Also, when xscreensaver is run as an ordinary user, it does not
lock the linux virtual console switching which makes it completely useless
as a screen locker.
Comment 1 Bill Nottingham 2000-04-11 10:45:59 EDT
xscreensaver will not lock the screen as root; it's designed that
way.

Unfortunately, it can't catch the switch VC keycodes, so it
can't prevent it.
Comment 2 Bill Nottingham 2000-05-16 12:11:59 EDT
*** Bug 11419 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2001-05-17 11:35:37 EDT
*** Bug 41108 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2001-09-26 17:41:18 EDT
*** Bug 54070 has been marked as a duplicate of this bug. ***
Comment 5 Bill Nottingham 2001-10-31 10:38:27 EST
*** Bug 55442 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2002-11-21 22:39:14 EST
*** Bug 74898 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2002-11-22 12:04:14 EST
*** Bug 78370 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.