This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 749064 - crash when examining disks with a VM where one disk is a software RAID member
crash when examining disks with a VM where one disk is a software RAID member
Status: CLOSED DUPLICATE of bug 873224
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-25 22:23 EDT by Adam Williamson
Modified: 2012-11-29 22:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-29 22:57:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the traceback (89.31 KB, text/plain)
2011-10-25 22:23 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2011-10-25 22:23:21 EDT
Well, I think the summary's accurate.

F16 TC2 and the pre-RC1 test image are both crashing for me after I select 'basic storage devices' in a particular VM. The VM has two disks attached; it's the second, vdb, which causes it to crash, I think. I think that disk is a 'stale' RAID member, it was part of a software RAID array I created for testing, but the other member of that array doesn't really exist any more.

abrt thinks the crash is a dupe of 731177, but I don't think so, as TC2 should have that selinux-policy fix. I'm attaching the traceback.
Comment 1 Adam Williamson 2011-10-25 22:23:37 EDT
Created attachment 530210 [details]
the traceback
Comment 2 Adam Williamson 2011-10-25 22:24:30 EDT
Proposing as a blocker as it's an installer crash, though it may wind up being NTH, since this is a pretty silly disk setup and I could probably work around it by zeroing out the drive or something.
Comment 3 Adam Williamson 2011-10-26 16:19:36 EDT
un-proposing, this is caused by dirty RAID which we don't support anyway - even if we fix the crash you wouldn't be able to install to it. so it's not critical.
Comment 4 Chris Lumens 2012-11-29 22:22:10 EST
Have you seen this at all in F18 testing?  I seem to recall some testing of incomplete RAIDs, but don't remember the exact conclusions.
Comment 5 Adam Williamson 2012-11-29 22:57:51 EST
Well, we have other bugs for it now. So we can probably close this one. But pretty much all incomplete multi-member devices are causing anaconda to crash in Beta, it has no handling for them. See https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=873224 , https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=876441 .

*** This bug has been marked as a duplicate of bug 873224 ***

Note You need to log in before you can comment on or make changes to this bug.