This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873224 - TypeError: cannot concatenate 'str' and 'NoneType' objects
TypeError: cannot concatenate 'str' and 'NoneType' objects
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:8efc488e57a5d47c8ac7df6d860...
: CommonBugs, Reopened
: 749064 873361 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-11-05 06:38 EST by Michal Kovarik
Modified: 2013-03-12 10:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 17:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (160.91 KB, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: product (6 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: type (9 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: storage.log (51.38 KB, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: version (11 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: environ (760 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: executable (14 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: anaconda.log (1.69 KB, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: syslog (58.61 KB, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: packaging.log (135 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: release (24 bytes, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details
File: program.log (17.29 KB, text/plain)
2012-11-05 06:38 EST, Michal Kovarik
no flags Details

  None (edit)
Description Michal Kovarik 2012-11-05 06:38:19 EST
Description of problem:
Previous installation:
root on software RAID0

I removed second harddrive (one raid member) then I started new installation.


Version-Release number of selected component:
anaconda-18.24

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.24 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 778, in addUdevMDDevice
:    devicelibs.mdraid.mddeactivate("/dev/" + name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1058, in addUdevDevice
:    device = self.addUdevMDDevice(info)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1902, in _populate
:    self.addUdevDevice(dev)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1850, in populate
:    self._populate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 398, in reset
:    self.devicetree.populate(cleanupOnly=cleanupOnly)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 104, in storageInitialize
:    storage.reset()
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:TypeError: cannot concatenate 'str' and 'NoneType' objects
Comment 1 Michal Kovarik 2012-11-05 06:38:22 EST
Created attachment 638503 [details]
File: anaconda-tb
Comment 2 Michal Kovarik 2012-11-05 06:38:25 EST
Created attachment 638504 [details]
File: product
Comment 3 Michal Kovarik 2012-11-05 06:38:27 EST
Created attachment 638505 [details]
File: type
Comment 4 Michal Kovarik 2012-11-05 06:38:29 EST
Created attachment 638506 [details]
File: ifcfg.log
Comment 5 Michal Kovarik 2012-11-05 06:38:31 EST
Created attachment 638507 [details]
File: storage.log
Comment 6 Michal Kovarik 2012-11-05 06:38:33 EST
Created attachment 638508 [details]
File: version
Comment 7 Michal Kovarik 2012-11-05 06:38:35 EST
Created attachment 638509 [details]
File: environ
Comment 8 Michal Kovarik 2012-11-05 06:38:37 EST
Created attachment 638510 [details]
File: executable
Comment 9 Michal Kovarik 2012-11-05 06:38:39 EST
Created attachment 638511 [details]
File: anaconda.log
Comment 10 Michal Kovarik 2012-11-05 06:38:42 EST
Created attachment 638512 [details]
File: syslog
Comment 11 Michal Kovarik 2012-11-05 06:38:44 EST
Created attachment 638513 [details]
File: hashmarkername
Comment 12 Michal Kovarik 2012-11-05 06:38:46 EST
Created attachment 638514 [details]
File: packaging.log
Comment 13 Michal Kovarik 2012-11-05 06:38:48 EST
Created attachment 638515 [details]
File: cmdline_file
Comment 14 Michal Kovarik 2012-11-05 06:38:50 EST
Created attachment 638516 [details]
File: release
Comment 15 Michal Kovarik 2012-11-05 06:38:52 EST
Created attachment 638517 [details]
File: program.log
Comment 16 Chris Lumens 2012-11-05 11:43:38 EST
*** Bug 873361 has been marked as a duplicate of this bug. ***
Comment 17 Reartes Guillermo 2012-11-05 14:34:39 EST
I got it too by booting F18b TC7 with only two of four raid5 members.
Comment 18 Michal Kovarik 2012-11-06 02:46:39 EST
Proposing as F18 Blocker.
Alpha release criterion:
12. The installer must be able to complete an installation using automatic partitioning to any sufficiently large target disk, whether unformatted, empty, or containing any kind of existing data
Comment 19 Adam Williamson 2012-11-06 03:16:42 EST
neither of those sounds like valid configurations. anaconda intentionally refuses to treat incomplete raid arrays like this as separate disks and just install to them, iirc. you have to wipe the RAID array first. could do with input from clumens and dlehman, but right now i'm -1 blocker.
Comment 20 Brian Lane 2012-11-06 19:24:30 EST
Anaconda doesn't support installing to degraded raids, but we also shouldn't blow up when one is encountered. This should be fixed for final, but I don't think we need it for beta since there is no data loss involved and you can easily work around it by wiping the disks with wipefs -a /dev/XXX
Comment 21 Adam Williamson 2012-11-07 12:22:44 EST
Discussed 2012-11-07 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-07/f18beta-blocker-review-7.2012-11-07-17.03.log.txt . Rejected as a Beta blocker as we won't support installing to this config anyway and the bug is only that we crash instead of erroring politely, but accepted as Final blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" (which is a kludge, but never mind).
Comment 22 Adam Williamson 2012-11-07 15:52:50 EST
Sigh. Sorry, I suck today.
Comment 23 Chris Lumens 2012-11-13 11:17:27 EST
I believe dlehman has plans for dealing with this fairly soon.
Comment 24 Reartes Guillermo 2012-11-16 09:20:41 EST
could not even accept fate.

Package: anaconda-18.29
OS Release: Fedora release 18-Beta-TC9
Comment 25 Adam Williamson 2012-11-16 15:38:34 EST
reartes: same reproducer as before, an incomplete RAID array?
Comment 26 Reartes Guillermo 2012-11-16 16:23:45 EST
In comment #24, anaconda boots directly to the black screen + the 'unknown error' reported. 

There is an mdadm array (most likely partial) on sdc, but in this case i do not reach the welcome screen.
Comment 27 David Lehman 2012-11-16 16:36:41 EST
(In reply to comment #26)
> In comment #24, anaconda boots directly to the black screen + the 'unknown
> error' reported. 
> 
> There is an mdadm array (most likely partial) on sdc, but in this case i do
> not reach the welcome screen.

Reaertes, feel free to keep plugging away with incomplete md arrays if you want to, but we aren't ready to start working on handling for such things at this point. Incomplete lvm/md setups is mostly something that we see with uber-testers like you and the occasional user who move drives from box to box. Once we have most of the normal/real-world operations working well we can move on to these more esoteric problems. Until then, don't expect this stuff to work.
Comment 28 Adam Williamson 2012-11-22 00:40:02 EST
commonbugs -> we need to document that incomplete RAID, LVM, btrfs etc multi-disk devices may cause crashes.
Comment 29 David Cantrell 2012-11-27 16:47:08 EST
Had four virtio disks configured as a RAID volume.  Shut down guest, removed the last three virtio disks and left one, started new install, hit this.

Package: anaconda-18.29.2
OS Release: Fedora release 18-Beta
Comment 30 Adam Williamson 2012-11-29 22:57:51 EST
*** Bug 749064 has been marked as a duplicate of this bug. ***
Comment 31 David Lehman 2012-12-13 22:28:46 EST
I tested a patch for this today. It works well, but needs some ui handling before I can call it done.
Comment 32 Fedora Update System 2012-12-18 20:34:46 EST
anaconda-18.37.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.4-1.fc18
Comment 33 Fedora Update System 2012-12-19 17:41:34 EST
Package anaconda-18.37.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20677/anaconda-18.37.4-1.fc18
then log in and leave karma (feedback).
Comment 34 Fedora Update System 2012-12-20 00:36:20 EST
anaconda-18.37.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 35 Kamil Páral 2012-12-20 05:34:26 EST
Michal (or anyone else who reproduced the problem), can you please verify the fix with smoke9 image?
http://dl.fedoraproject.org/pub/alt/qa/20121219_f18-smoke9/
Comment 36 Michal Kovarik 2012-12-20 10:07:52 EST
When I started installation on system with one RAID0 member, select INSTALLATION DESTINATION, select harddrive, click on continue, click on Reclaim space, delete all partitions, click on Reclaim space, traceback report occured and system is rebooted directly.

When I clicked on "I don't need help; let me customize disk partitioning", removed partitions and create new disk layout, then installation finished successfully.
Comment 37 David Lehman 2012-12-20 13:21:54 EST
(In reply to comment #36)
> When I started installation on system with one RAID0 member, select
> INSTALLATION DESTINATION, select harddrive, click on continue, click on
> Reclaim space, delete all partitions, click on Reclaim space, traceback
> report occured and system is rebooted directly.

Obviously a different error, but reproducible here.
Comment 38 David Lehman 2012-12-20 15:23:32 EST
New bug reported to track crash reported in comment 36: 889330
Comment 39 Adam Williamson 2012-12-20 16:16:09 EST
So can we close this one?
Comment 40 David Lehman 2012-12-20 17:49:28 EST
Yes, to hit the bug from comment 36 you must have already passed the code that triggered this bug.

Note You need to log in before you can comment on or make changes to this bug.