Bug 749281 - <type 'exceptions.TypeError'>: unsupported operand type(s) for +: 'NoneType' and 'str'
Summary: <type 'exceptions.TypeError'>: unsupported operand type(s) for +: 'NoneType' ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Keywords:
Depends On: 767679
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-10-26 15:49 UTC by Alexander Todorov
Modified: 2014-10-06 13:46 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-06-20 11:59:46 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Alexander Todorov 2011-10-26 15:49:39 UTC
Description of problem:

During rhn_register form the command line it fails with this :


Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 76, in <module>
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 74, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 58, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1272, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1220, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/up2date_client/tui.py", line 678, in __init__
    hardware_text += hw['ipaddr'] + "  "
<type 'exceptions.TypeError'>: unsupported operand type(s) for +: 'NoneType' and 'str'



I suspect this is due to my computer having issues with network connectivity. It failed 2 times, then I was able to get past the hardware info screen (but it failed to connect to RHN) and on the next run it failed again with this traceback.

This is on a freshly installed 6.1 Workstation system.

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-61.el6.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jan Pazdziora 2011-11-24 14:54:57 UTC
Setting devel ack -- fix is in Spacewalk master, e13f9db192792fe9501b884c5a595cccc887ede6.

Comment 2 Jan Pazdziora 2011-11-24 14:55:22 UTC
For QA: this should likely happen if the client is IPv6-only machine.

Comment 3 Miroslav Suchý 2012-01-09 17:25:27 UTC
This will be fixed as side effect of bug 767679.
Leaving for QA to test.

Comment 7 errata-xmlrpc 2012-06-20 11:59:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html


Note You need to log in before you can comment on or make changes to this bug.