Bug 767679 - RFE: support IPv6 in rhn-client-tools
Summary: RFE: support IPv6 in rhn-client-tools
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools   
(Show other bugs)
Version: 6.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 743259
Blocks: 569790 749281 767680
TreeView+ depends on / blocked
 
Reported: 2011-12-14 16:26 UTC by Miroslav Suchý
Modified: 2018-11-26 17:27 UTC (History)
4 users (show)

Fixed In Version: rhn-client-tools-1.0.0-76.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 743259
: 767680 (view as bug list)
Environment:
Last Closed: 2012-06-20 11:59:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Miroslav Suchý 2011-12-14 16:26:14 UTC
We need to support rhn-client-tools (and registration to RHN Satellite) in enviroment where machine has IPv4 & IPv6 or IPv6 only address.

+++ This bug was initially created as a clone of Bug #743259 +++

rhn-client-tools: general hardware.py audit

    several places where we need to be IPv6 aware
    findHostByRoute() 
    read_network()

--- Additional comment from msuchy@redhat.com on 2011-10-04 09:44:50 EDT ---

spacewalk.git commit 92331fb66a4c4430ac3c9a700eb6210b068bded9

--- Additional comment from msuchy@redhat.com on 2011-10-04 10:38:52 EDT ---

commit e13f9db192792fe9501b884c5a595cccc887ede6

--- Additional comment from msuchy@redhat.com on 2011-10-06 06:11:56 EDT ---

commit 376e97090d3b254427eb55d3286f7d8e5ade046b

--- Additional comment from msuchy@redhat.com on 2011-10-06 06:15:54 EDT ---

commit aa6bc29f2d95d2cffb9d4cfdfbbddfdeef634e7f

--- Additional comment from msuchy@redhat.com on 2011-10-06 11:16:33 EDT ---

commit 09c74da5c1b283c797a85fb5e652e8c6ac6356f5

--- Additional comment from msuchy@redhat.com on 2011-10-07 07:33:13 EDT ---

commit 181e93e077b831d6f6b425898444906b96488cb1

--- Additional comment from msuchy@redhat.com on 2011-10-11 07:41:02 EDT ---

commit: a5b395906483a4250afea040bb0af9cda1c82864

--- Additional comment from msuchy@redhat.com on 2011-10-19 07:09:02 EDT ---

commit 0cbbafd03376128946b3fd057044931128bd5586
and bc83988eb4d47db439f3226198cee039075ec396

--- Additional comment from msuchy@redhat.com on 2011-10-31 08:46:22 EDT ---

commit 414b4f6c74187d48c9af55b76875f858474fd44c

--- Additional comment from msuchy@redhat.com on 2011-12-02 08:21:58 EST ---

commits:
94e5593adca38cd5dc4358c020fef6f2e8e2f1a2
120f042027d5f2829dc152aadec658cca9d2252d
ea2d344fc0be493428ff2b9a1659e5c22b1ba5c8

--- Additional comment from msuchy@redhat.com on 2011-12-09 06:04:27 EST ---

commit 66e376f35299f9927b3de692ee5998bd12371455

Comment 1 Milan Zázrivec 2012-01-04 14:17:27 UTC
Yet another commit is needed: 60b361bba52f028941c657eb4bef7fd41cb35a0c

Comment 2 Miroslav Suchý 2012-01-11 15:17:16 UTC
another commit 7c2b37ad9dd2a972e04bb31cbb021047c6572564

Comment 3 Miroslav Suchý 2012-01-11 15:41:02 UTC
I will omit commit ea2d344fc0be493428ff2b9a1659e5c22b1ba5c8 by purpose to not create regression in behaviour.

Comment 4 Miroslav Suchý 2012-01-11 16:01:14 UTC
Cherry-picked as:
* d847c3a continue to search for the hostname if IPv6 is disabled
* f91ec9a 569790 - for scope on rhel5 do s/global/universe/
* 6b40627 IPv6: assign to hostname only if we are unable to resolve it
* 2c55ddd 743259 - take hostname of client instead of server
* ff3ea62 IPv6: IPv4 is most probably set up better, lets overwrite IPv6 values (if mismatch)
* 8011abf 743259 - initialize variable before use
* 41b1135 743259 - RHEL5 now has python-ethtool 0.6 - simplify code
* 316b651 743259 - get_ipv6_addresses does not return one item, but list
* 2311ed0 743259 - if IPv6 is not present, send empty string instead of None
* fe11192 743259 - send IPv6 addresses only if server support it
* b8bccc0 743259 - really send ipv6 address
* 6a0fcb6 743259 - findHostByRoute now returns both IPv4 and IPv6 and the same for Hardware class 
* f0a0c97 743259 - make findHostByRoute() IPv6 aware

Comment 11 errata-xmlrpc 2012-06-20 11:59:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html


Note You need to log in before you can comment on or make changes to this bug.