Bug 74935 - LOWPOWER_SERVICES are never started if POWER_SERVICES is undefined.
LOWPOWER_SERVICES are never started if POWER_SERVICES is undefined.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
: 90852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-02 17:45 EDT by Aleksey Nogin
Modified: 2015-01-07 19:00 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.0.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-19 16:06:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix the script (against apmd-3.0.2-14). (785 bytes, patch)
2003-01-21 17:42 EST, Aleksey Nogin
no flags Details | Diff

  None (edit)
Description Aleksey Nogin 2002-10-02 17:45:55 EDT
I see several bugs in /etc/sysconfig/apm-scripts/apmscript

1) The most important one is that the code for starting up LOWPOWER_SERVICES is
inside the ``[ -n "$POWER_SERVICES" ]'' test, so if POWER_SERVICES is empty or
undefined, then LOWPOWER_SERVICES will never be restarted.

2) What if I get into a lowerpower state and then insert a secondary battery -
will LOWPOWER_SERVICES be restarted then? The current script appears to only try
to restart them when laptop is plugged back into AC...

3) What if I get into a lowerpower state, suspend the laptop, plug it into AC
and then resume - will the LOWPOWER_SERVICES be restarted then? Havn't tested
that yet though.
Comment 1 Aleksey Nogin 2003-01-06 05:25:26 EST
I believe these problems still exist in Phoebe
Comment 2 Aleksey Nogin 2003-01-21 17:42:50 EST
Created attachment 89492 [details]
Patch to fix the script (against apmd-3.0.2-14).

This problem still exists in Phoebe-2 (apmd-3.0.2-14). Attaching a patch that
(hopefully) fixes it.
Comment 3 Bill Nottingham 2003-05-19 16:06:59 EDT
Fixed in 3.0.2-19, slightly differently.
Comment 4 Aleksey Nogin 2003-05-30 05:42:31 EDT
*** Bug 90852 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.