Bug 74958 - GUI package management tool uninstalls more packages than expected
GUI package management tool uninstalls more packages than expected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 74546 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 01:40 EDT by Michael Wardle
Modified: 2014-01-21 17:48 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 16:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Wardle 2002-10-03 01:40:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Today I performed a clean workstation class install of Red Hat 8.0,
accepting the default packages.

After the newly installed system loaded for the first time, I used
the Red Hat GUI Package Management tool to install packages from the
"Authoring and Publishing" group and installed some other packages
(such as samba) at the same time.  I let the Package Management tool
install and uninstall as necessary then quit it.  Soon after, I
decided I didn't want the authoring packages after all, so I started
the Package Management tool again, and unchecked the authoring package
group, and again allowed the tool to install and uninstall, then quit.

I then restarted my system, but rather than getting the GNOME 2
display manager (gdm 2), I was presented with xdm.  On further
investigation, many GNOME-related packages had been uninstalled,
including gdm, nautilus, and evolution.

In the process of reinstalling gdm, I was told that this depended
on scrollkeeper, which in turn depended on openjade and docbook-dtds,
both of which would probably have been uninstalled when I unchecked
the authoring packages group.

My guess would be that the package management tool tries to handle
dependencies, but got a little overexcited and uninstalled anything
that depended on the authoring packages such as docbook and openjade.

For what it's worth, this issue does seem to be similar to bug 74546.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Jeremy Katz 2002-10-11 16:04:13 EDT
Added scrollkeeper to the blacklisted of packages in CVS to keep it from getting
removed and fixed the comps file in CVS so that this won't be a problem in the
next release.

I should have an updated redhat-config-packages package available at
http://people.redhat.com/~katzj/redhat-config-packages/ in the next week or so
with this and a few other fixes.
Comment 2 Jeremy Katz 2002-10-11 16:24:11 EDT
*** Bug 74546 has been marked as a duplicate of this bug. ***
Comment 3 Seth Vidal 2003-11-19 01:51:36 EST
triage->currentrelease

this seems fairly old by now.

Note You need to log in before you can comment on or make changes to this bug.