Bug 74960 - Display corruption with cyber 9388
Display corruption with cyber 9388
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82780
  Show dependency treegraph
 
Reported: 2002-10-03 02:36 EDT by Adam Haile
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.3.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 14:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file (3.29 KB, text/plain)
2002-10-08 13:04 EDT, Adam Haile
no flags Details
XFree86 log file when using trident driver (68.61 KB, text/plain)
2002-10-08 13:07 EDT, Adam Haile
no flags Details

  None (edit)
Description Adam Haile 2002-10-03 02:36:32 EDT
On my NEC Versa SX laptop with a trident cyber9388 video chipset, any horizontal
line of pure white has only tbe right-most pixel actually white, and all others
are a drab green color.  Other colors are not affected, and it appears that this
is the only corruption, but it's a big one.  The majority of text displays are
borderline unreadable, since most use either white text or a white background.

The last working version of XFree86 on my laptop was 4.1.0-3.  All newer
versions have displayed either the technicolor distortion described in bug
#61834 or this white-field distortion.

I tried the alternate trident_drv.o drivers available at www.xfree86.org/~alanh
and people.redhat.com/~mharris, and both of them displayed the same problem.
Comment 1 Mike A. Harris 2002-10-05 18:21:04 EDT
Cc'ing Trident driver maintainer

Please attach your X server log, and X config file.

Also, for troubleshooting purposes, does the problem disappear if you
use Option "noaccel"?
Comment 2 Adam Haile 2002-10-08 13:04:23 EDT
Created attachment 79405 [details]
XF86Config file
Comment 3 Adam Haile 2002-10-08 13:07:19 EDT
Created attachment 79406 [details]
XFree86 log file when using trident driver
Comment 4 Adam Haile 2002-10-08 13:13:46 EDT
Problem is unchanged when I set Option "NoAccel".  However, I did recently
figure out that the display is fine under the (unaccelerated, slow) "vesa" driver.

By the way, I live in Durham and could stand being without my laptop for a week
or so if it would help you to see the actual machine.  Let me know if you're
interested and I could bring it by the Redhat offices.
Comment 5 Carl T. Miller 2002-11-17 18:45:22 EST
I found that using the vesa driver in RH 8.0 fixed my display problems as well.
It's a Fujitsu Lifebook 735DX.  The video card is a Trident 9385 and redhat-
config-xconfig discovers it as a TGUI9660.

When I run startx, the display looks bad for the first several seconds, with
vertical lines of various colors.  The screen then clears and Xwindows starts
normally.
Comment 6 Alan Hourihane 2003-06-25 13:10:12 EDT
upgrade to XFree86 4.3.0 and if the problem persists log it in the XFree86 
Bugzilla database.

I'm removing myself as a CC.
Comment 7 Mike A. Harris 2003-06-25 14:44:55 EDT
I agree with Alan H's suggestion, if the problem still exists in Red Hat Linux
9 using XFree86 4.3.0, please open a new bug report in XFree86 bugzilla at
http://bugs.xfree86.org and feel free to add me as a CC
<mharris@www.linux.org.uk>

The 'vesa' driver, while suboptimal, does work as a workaround as indicated
above, so this problem is unlikely to ever be fixed in XFree86 4.2.x in
Red Hat Linux 8.0.

Closing as CURRENTRELEASE.  Reopen and attach upstream bug report URL if this
recurs in RHL 9.

Note You need to log in before you can comment on or make changes to this bug.