Bug 74979 - TB neat:770:on_dnsEditButton_clicked
Summary: TB neat:770:on_dnsEditButton_clicked
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 7.2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 72256 (view as bug list)
Depends On:
Blocks: rcn-7.3
TreeView+ depends on / blocked
 
Reported: 2002-10-03 11:32 UTC by Michal Kuty
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-14 21:04:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:257 high SHIPPED_LIVE Updated redhat-config-network package available 2003-05-06 04:00:00 UTC
Red Hat Product Errata RHBA-2002:267 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-02-07 15:19:58 UTC

Description Michal Kuty 2002-10-03 11:32:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Program every time crashes when clicking on EDIT button in DNS setup.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.opening rhn conf. tool
2.selecting DNS card
3.clicking on edit button
	

Actual Results:  program crashed with error message:

raceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 770, in on_dnsEditButton_clicked
    name = clist.get_text(clist.selection[0], 0)
IndexError: list index out of range


Additional info:

Comment 1 Harald Hoyer 2002-10-23 09:41:34 UTC
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.

Comment 2 Harald Hoyer 2002-11-20 18:02:53 UTC
*** Bug 72256 has been marked as a duplicate of this bug. ***

Comment 3 John Flanagan 2003-02-14 21:04:24 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html



Note You need to log in before you can comment on or make changes to this bug.