Bug 749984 - [Xfce] Some parts of the menu are in english after a netinstall with french translation installed.
[Xfce] Some parts of the menu are in english after a netinstall with french t...
Status: CLOSED DUPLICATE of bug 750380
Product: Fedora Localization
Classification: Fedora
Component: French [fr] (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Martin-Gomez Pablo
Kendall Fay
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-29 08:58 EDT by perfectop
Modified: 2011-10-31 17:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-31 17:05:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the menu (553.02 KB, image/png)
2011-10-29 08:58 EDT, perfectop
no flags Details
/etc/xdg/menus/xfce-applications.menu version xfce 4.8.6 (5.54 KB, application/octet-stream)
2011-10-30 19:00 EDT, Cyril François
no flags Details
/usr/share/desktop-directories/Network.directory version xfce 4.8.6 (12.39 KB, application/octet-stream)
2011-10-30 19:01 EDT, Cyril François
no flags Details

  None (edit)
Description perfectop 2011-10-29 08:58:25 EDT
Created attachment 530782 [details]
Screenshot of the menu

Description of problem:
After a netinstall of Fedora 16 x86_64 with french support, some parts of the xfce menu appears in english and some icons are missing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform a netinstall of Fedora 16
2. Select graphical desktop, then unselect Gnome, select Xfce and french translation.
3. Select default configuration when first log in.
  
Actual results:
Some parts of the menu appears in english and some icons are missing.

Expected results:
All entries in the menu in french and all the icons are here.

Additional info:
Comment 1 Cyril François 2011-10-30 09:54:55 EDT
In regard to the menu items which appear to be in english, it will be fixed by the next release. Indeed the traduction team has done the job.

Otherwise for missing icons, do you use particular icon theme or no-default applications ?

It will be nice if you could give a screenshot of icon problem, because in your current shared picture I don't see missing icon.

Best regards.
Comment 2 perfectop 2011-10-30 11:13:26 EDT
Sorry about the icons, i misspoked. I meant that some icons are not good (in my screen, the icons relating to Accesories, Multimedia, Network, Office, System). 

Maybe this is due to the "bad translating" : the icons are linked to the name of the entry in french and not in english. Or maybe the good icons are missing in the default icon theme that i use. 

In all cases, the icons were not like that in Fedora 15.
Comment 3 Cyril François 2011-10-30 18:58:52 EDT
I've installed xfce thanks to 'yum groupinstall xfce' command. Everything is fine in the menu.

The 'bad translation' has no influence on the icon. The icon is defined by the 'Icon' entry in /usr/share/desktop-directories/*.directory. Maybe it's a previous problem with garcon which monitors *.menu files, but resolved at present.

What's your 'xfce4-panel' and 'garcon' version?
For me : xfce4-panel 4.8.6 and garcon 0.1.9

I propose you to make an update and see if there're betterments.
Otherwise you can see (and share) /etc/xdg/menus/xfce-applications.menu and /usr/share/desktop-directories/Network.directory . I'll share mine to permit you to compare.
(Network icon malfunctions on your xfce desktop).

Best regards.
Comment 4 Cyril François 2011-10-30 19:00:19 EDT
Created attachment 530864 [details]
/etc/xdg/menus/xfce-applications.menu  version xfce 4.8.6
Comment 5 Cyril François 2011-10-30 19:01:40 EDT
Created attachment 530865 [details]
/usr/share/desktop-directories/Network.directory version xfce 4.8.6
Comment 6 perfectop 2011-10-31 04:15:48 EDT
The only difference between you and me is that I didn't have Network.directory in /usr/share/desktop-directories/. After a copy-paste of your in this folder and a reboot, Internet entry in the menu is correct. I gather I don't have the others .directory files related to the others entries in my menu.
Comment 7 Cyril François 2011-10-31 09:04:14 EDT
Because it's a problem specific to XFCE (package, missing *.directory files...) you should notify the XFCE team or the maintainer. Indeed it's clearly not a traduction problem.

However if you want your missing *.directory files, I can share mine by e-mail. Indeed I don't know what package provides *.directory files (garcon, xfdesktop, xfce4-panel ? maybe... ).

Best Regards
Comment 8 perfectop 2011-10-31 14:00:10 EDT
Yeah. Thanks for your time :) I close this bug report now ?
Comment 9 Cyril François 2011-10-31 16:32:19 EDT
Don't mention that. Yes you can close this.

Best regards.
Comment 10 Christoph Wickert 2011-10-31 17:58:19 EDT

*** This bug has been marked as a duplicate of bug 750380 ***

Note You need to log in before you can comment on or make changes to this bug.