This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 750380 - Missing some *.directory files in /usr/share/desktop-directories/
Missing some *.directory files in /usr/share/desktop-directories/
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: garcon (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
AcceptedNTH
:
: 749984 754328 (view as bug list)
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-10-31 17:26 EDT by perfectop
Modified: 2012-06-01 23:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: garcon-0.1.9-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 23:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of /usr/share/desktop-directories (65.91 KB, image/png)
2011-10-31 17:26 EDT, perfectop
no flags Details

  None (edit)
Description perfectop 2011-10-31 17:26:50 EDT
Created attachment 531043 [details]
Screenshot of /usr/share/desktop-directories

Description of problem:
Missing some *.directory files in /usr/share/desktop-directories/ after a netinstall of Fedora 16 x86_64, causing a lack of translations and a display of a wrong icon in the menu (see https://bugzilla.redhat.com/show_bug.cgi?id=749984 for more informations).

Version-Release number of selected component (if applicable):
garcon-0.1.9-1.fc16.x86_64

How reproducible:


Steps to Reproduce:
1. Perform a netinstall of Fedora 16
2. Select graphical desktop, then unselect Gnome, select Xfce and french
translation.
3. Select default configuration when first log in.

Actual results:
Some parts of the menu are not translate and some icons are wrong, causing by the absence of some *.directory files.

Expected results:
Good translations and good icons.


Additional info:
Comment 1 Christoph Wickert 2011-10-31 17:58:19 EDT
*** Bug 749984 has been marked as a duplicate of this bug. ***
Comment 2 Christoph Wickert 2011-10-31 18:00:59 EDT
The missing files are provided by the gnome-menus package, please install it.

I am not sure what I should do here: Making garcon depend on gnome-menus but having inconsistent and untranslated menus is bad, too. The reson for me to patch garcon to use the files from redhat-menus and gnome-menus was that they have more and better translations than the files of Xfce.
Comment 3 perfectop 2011-10-31 18:13:28 EDT
Thanks for your reactivity.

I think making garcon depend on gnome-menus will not be too annoying for the user, its installation not weighing too heavy on the system.
Comment 4 Christoph Wickert 2011-10-31 18:24:43 EDT
Did it pull in any additional packages on your system? I cannot test with the Xfce spin because gnome-menus is already installed there anyway (that's why I did not notice the bug).

I think in long term we want to drop the patch because we want Xfce to be independent of the changes in gnome-menus and redhat-menus. This is not the first time this caused us trouble.

But before I am going to drop the patch I'd rather try to revive and update redhat-menus, then we can have consistent, desktop-independent and well translated menus in all desktop environments in Fedora.

Kevin, Adam, your take on this?
Comment 5 perfectop 2011-10-31 18:48:53 EDT
No additional package was pull on my system. In a short term, making garcon depend on gnome-menus could be a good solution.

I alsa have a question, is it normal that Openbox has been installed with my netinstall of Xfce ?
Comment 6 Christoph Wickert 2011-10-31 20:01:31 EDT
No, this is a bug. firstboot needs "firstboot(windowmanager)" and in Xfce xfwm4 should provide it. I filed bug 750397 for this.

You remove openbox-libs should fix your problem.
Comment 7 Christoph Wickert 2011-11-16 03:35:10 EST
*** Bug 754328 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-05-05 19:01:43 EDT
garcon-0.1.9-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/garcon-0.1.9-4.fc17
Comment 9 Fedora Update System 2012-05-05 19:03:08 EDT
garcon-0.1.9-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/garcon-0.1.9-4.fc16
Comment 10 Christoph Wickert 2012-05-05 19:10:53 EDT
I am proposing this bug as F17 NTH. Rationale:
- Missing icons and translations are a violation of the "Menu sanity" release criteria.
- As the menu (slightly) changes with this update, updating the package after the F17 release could be considered a violation of the updates policy.
- While I consider this a blocker for Xfce, it cannot be release blocker as per definition only GNOME and KDE can delay a release.

Please treat this update as important and make sure this update gets tagged into final. TIA!
Comment 11 Fedora Update System 2012-05-06 00:02:00 EDT
Package garcon-0.1.9-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing garcon-0.1.9-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7402/garcon-0.1.9-4.fc17
then log in and leave karma (feedback).
Comment 12 Dennis Gilmore 2012-05-11 22:22:40 EDT
+1 nth from me
Comment 13 Adam Williamson 2012-05-12 20:45:51 EDT
+1 NTH for an Xfce blocker.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Christoph Wickert 2012-05-13 08:18:31 EDT
So, what is needed to get this tagged final? We have positive karma, the package was submitted for stable and +2 from QA and rel-eng. What's next?
Comment 15 Bruno Wolff III 2012-05-13 09:14:16 EDT
+1 NTH for xfce blocker
Comment 16 Tim Flink 2012-05-14 13:40:16 EDT
I'm also +1 NTH for XFCE blocker

That makes +4, moving to accepted.
Comment 17 Adam Williamson 2012-05-14 22:26:44 EDT
cwickert: don't +1 your own updates. naughty naughty. :)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Christoph Wickert 2012-05-15 05:14:01 EDT
I like being naughty ;) but in this case I don't think I am. I know the problem, I know what to look for so I consider myself a good tester.
Comment 19 Adam Williamson 2012-05-15 11:28:39 EDT
That's as maybe, but FESCo stated specifically that it's not allowed, as part of the policy.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Fedora Update System 2012-05-15 23:15:20 EDT
garcon-0.1.9-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2012-06-01 23:57:59 EDT
garcon-0.1.9-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.