Bug 750149 - change root's passwd in setup report "/etc/shadow" device busy
change root's passwd in setup report "/etc/shadow" device busy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node (Show other bugs)
5.8
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: ZStream
Depends On:
Blocks: 796807
  Show dependency treegraph
 
Reported: 2011-10-31 03:57 EDT by Guohua Ouyang
Modified: 2016-04-26 11:04 EDT (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-1.0-85.el5
Doc Type: Bug Fix
Doc Text:
Previously attempts to change the root user's password resulted in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 12:54:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (190.15 KB, image/png)
2011-10-31 03:58 EDT, Guohua Ouyang
no flags Details

  None (edit)
Description Guohua Ouyang 2011-10-31 03:57:55 EDT
Description of problem:
change root's passwd in setup report "/etc/shadow" device busy.

Version-Release number of selected component (if applicable):
5.8-20111028.0

How reproducible:
50%.

Steps to Reproduce:
1. install RHEV-H manually.
2. after installation is finished, reboot.
3. login with root.
4. change root's passwd in setup.

Actual results:
change passwd in setup report "/etc/shadow" device busy.

Expected results:
It should not report "/etc/shadow" device busy.
Comment 1 Guohua Ouyang 2011-10-31 03:58:50 EDT
Created attachment 530912 [details]
screenshot
Comment 4 Guohua Ouyang 2011-11-23 04:42:24 EST
Verified on 5.8-20111121.0, no this message show anymore.
Comment 5 Mike Burns 2012-01-12 19:38:10 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Attempts to change the root user's password would result in a "device busy" error caused by multipathd keeping the file busy.  A multipathd restart in the password setting script solves this problem.
Comment 6 Guohua Ouyang 2012-02-05 21:27:31 EST
Re-open this bug, because it's reproduced on 5.8-20120202:


Red Hat Enterprise Virtualization Hypervisor release 5.8 (20120202.0)
Virtualization hardware is unavailable.
(No virtualization hardware was detected on this system)


 Hypervisor Configuration Menu

1) Configure authentication	       5) Configure the host for RHEV
2) Set the hostname		       6) View logs
3) Networking setup		       7) Exit Hypervisor Configuration Menu
4) Register Host to RHN
Choose an option to configure: 1



SSH password authentication is currently enabled.

1) Set the administrator password      3) Return to menu
2) Toggle SSH password authentication
Choose an option: 1


 Configure passwords 


Set the system administrator's (root) password:
Stopping multipathd daemon:                                [  OK  ]
Starting multipathd daemon:                                [  OK  ]
cp: cannot remove `/etc/shadow': Device or resource busy
New UNIX password:
Comment 7 Guohua Ouyang 2012-02-05 22:01:50 EST
it's odd, I tested this on another machine, cannot reproduce it.
lower the priority.
Comment 14 Stephen Gordon 2012-02-24 15:15:24 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Attempts to change the root user's password would result in a "device busy" error caused by multipathd keeping the file busy.  A multipathd restart in the password setting script solves this problem.+Attempts to change the root user's password would result in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.
Comment 15 Stephen Gordon 2012-07-03 10:45:41 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Attempts to change the root user's password would result in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.+Previously attempts to change the root user's password resulted in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.
Comment 17 cshao 2012-08-17 01:19:45 EDT
Test version:
rhev-hypervisor5-5.9-20120808.0.el5
ovirt-node-1.0-86.el5

test steps:
1. install RHEV-H manually.
2. after installation is finished, reboot.
3. login with root.
4. change root's passwd in setup.

Test result:
1) Set the administrator password      3) Return to menu
2) Toggle SSH password authentication
Choose an option: 1


 Configure passwords 


Set the system administrator's (root) password:
New UNIX password: 
BAD PASSWORD: it is WAY too short
Retype new UNIX password: 
Changing password for user root.
passwd: all authentication tokens updated successfully.
 File persisted

Successfully persisted /etc/shadow


1. RHEV-H will not report "/etc/shadow" device busy. 
2. Login RHEV-H with the new password can successful.
So the bug is fixed, change bug status to VERIFIED.
Comment 19 errata-xmlrpc 2013-01-08 12:54:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0143.html

Note You need to log in before you can comment on or make changes to this bug.