Bug 796807 - change root's passwd in setup report "/etc/shadow" device busy
change root's passwd in setup report "/etc/shadow" device busy
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ovirt-node (Show other bugs)
5.8
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
: ZStream
Depends On: 750149
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-23 12:14 EST by Chris Pelland
Modified: 2016-04-26 09:55 EDT (History)
13 users (show)

See Also:
Fixed In Version: ovirt-node-1.0-84.el5_8.1
Doc Type: Bug Fix
Doc Text:
Attempts to change the root user's password would result in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 09:06:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2012-02-23 12:14:35 EST
This bug has been copied from bug #750149 and has been proposed
to be backported to 5.8 z-stream (EUS).
Comment 4 Mike Burns 2012-02-23 13:14:11 EST
http://gerrit.virt.bos.redhat.com/gerrit/47
Comment 7 Stephen Gordon 2012-02-24 15:15:29 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Attempts to change the root user's password would result in a "device busy" error on the "/etc/shadow/" file. This occurred because multipathd held a lock on the file. The script that changes the password now restarts multipathd to release the lock, avoiding the "device busy" error.
Comment 8 errata-xmlrpc 2012-03-07 09:06:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0367.html

Note You need to log in before you can comment on or make changes to this bug.