Bug 750363 - new package with iOS 5 support
new package with iOS 5 support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libimobiledevice (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
: 750372 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-31 15:57 EDT by Thorsten Scherf
Modified: 2012-03-25 11:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 08:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libimobiledevice SRPM with iOS 5 support (461.74 KB, application/x-rpm)
2011-10-31 15:57 EDT, Thorsten Scherf
no flags Details

  None (edit)
Description Thorsten Scherf 2011-10-31 15:57:19 EDT
Created attachment 531030 [details]
libimobiledevice SRPM with iOS 5 support

Description of problem:
The current package in F16 (and rawhide) doesn't support iOS 5. I've created a new package that contains most patches from upstream. A single patch is missing which requires gnutls-2.2 support, which is actually not available in Fedora so far. The new package is attached. Would be good to integrate it into latest Fedora 16 and rawhide channel. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Peter Robinson 2011-10-31 16:49:49 EDT
I'm awaiting a new upstream release
Comment 2 Peter Robinson 2011-10-31 16:49:58 EDT
*** Bug 750372 has been marked as a duplicate of this bug. ***
Comment 3 Thorsten Scherf 2011-11-01 04:23:02 EDT
I don't think a new upstream release will be issued before music sync with iOS 5 works again. Unknown ETA afaik. Why not use an intermediate fedora release until a new upstream release is available. Ubuntu has these fixes already included.
Comment 4 Peter Robinson 2011-11-01 04:34:25 EDT
ubuntu is not a reason
Comment 5 Thorsten Scherf 2011-11-03 15:58:08 EDT
what is the reason then?
Comment 6 Jeff Raber 2011-11-15 09:50:36 EST
+1 for an interim release that enables at least partial use of iOS5 devices.  (I'd like to get the photos off of my wife's phone.  I'm sure others have the same issue.)

The patches from upstream to enable support for iOS5 are fairly minimal (actually, I think only the f0487376671... patch is required for iOS5 support, which is a 4 line patch).

Peter, could we do a build and leave it in updates-testing for a while?  Then the people that really want access to their idevice won't have to build their own patched version.
Comment 7 Peter Robinson 2011-11-15 09:56:37 EST
its on my todo list
Comment 8 Peter Robinson 2011-11-15 09:58:47 EST
(In reply to comment #5)
> what is the reason then?

I generally follow upstream releases. Its easier to deal with than pulling patches and trying to work out what broke when it doesn't go the right way. Its not sustainable to pull random patches for every different patches
Comment 9 Jeff Raber 2011-12-04 22:51:55 EST
There is a new build available for F16 that supports iOS5 devices.

If you'd like you can install the updated package using the following command:
'yum --enablerepo=updates-testing libimobiledevice'

You can leave feedback about that package using the link below.  (positive feedback help to get this package moved into 'stable')

https://admin.fedoraproject.org/updates/FEDORA-2011-16681/libimobiledevice-1.1.1-3.fc16
Comment 10 Jan Wildeboer 2011-12-06 08:12:36 EST
Minor pedantic nitpick:

The command ofcourse is

yum --enablerepo=updates-testing update libimobiledevice

(missing update command)

Am running the updated version on my F16 x86_64 box and seeing every second:

xhci_hcd 0000:0f:00.0: WARN: short transfer on control ep

in my /var/log/messages - goes away when I unplug my iOS5 device (an iPhone 3GS to be precise).
Comment 11 Jan Wildeboer 2011-12-06 08:20:11 EST
So with the libimobiledevice-1.1.1-3.fc16 installed in my Lenovo X1 with Fedora 16, x86_64 I can confirm the following Just Works when connecting an iPhone 3GS with iOS 5.0.1:

- two devices show up in Nautilus, the iPhone and iPhone Documents.
- Shotwell imports pictures and videos with no problems
- Rhythmbox sees the music collection (didn't try anything beyond that)
- NetworkManager picks up the connection and starts using it (I have USB hotspot enabled on my iPhone and display shows a working connection)

Problems I see:

- See my previous comment for the xhci_hcd problems
- Devices cannot be ejected/unmounted via Nautilus (crashes gvfs, sending abrt report as we speak)

HTH
Comment 12 Jan Wildeboer 2011-12-06 08:23:06 EST
Added Bug #760539 to see also list. This is the result of abrt after I disconnected the iPhone 3 GS from my laptop.
Comment 13 Peter Robinson 2011-12-23 08:52:00 EST
In mainline F-16
Comment 14 Jinjer S 2012-03-24 17:58:40 EDT
Hello all, I'm using F15 + iphone 3Gs ios 5.01 + libidevicemobile 1.1.1-1 and getting "unhandled lockdown error -4" on iphone mount - Can this Fix be applied to F15 also, or some other solution which i can Use ?
Comment 15 Peter Robinson 2012-03-24 18:07:49 EDT
(In reply to comment #14)
> Hello all, I'm using F15 + iphone 3Gs ios 5.01 + libidevicemobile 1.1.1-1 and
> getting "unhandled lockdown error -4" on iphone mount - Can this Fix be applied
> to F15 also, or some other solution which i can Use ?

any reason you haven't upgraded to f-16?

There's a new upstream release and it's possible I'll push that back to f15 once I've had a chance to review the impact
Comment 16 Jinjer S 2012-03-24 19:11:49 EDT
Been working on tight dev schedule, can't afford to take the risk something will go wrong with upgrade at this point of time...

Anyway, tnx for quick replay - be waiting for fix.
Comment 17 Jeff Raber 2012-03-24 20:32:24 EDT
jinjer, you could try installing the F16 package; I think the risk would be minimal.  Worst case, it wouldn't work and you could revert to the F15 version.

You can get the latest F16 build RPMS from here: http://koji.fedoraproject.org/koji/buildinfo?buildID=276689
Comment 18 Jinjer S 2012-03-25 11:18:59 EDT
Did it, seems to be working perfectly so far.
libimobiledevice-1.1.1-3.fc16.x86_64.rpm
Much appreciated guys.

Note You need to log in before you can comment on or make changes to this bug.