Bug 75061 - ami font display broken, doesn't pop-up
ami font display broken, doesn't pop-up
Status: CLOSED DUPLICATE of bug 101377
Product: Red Hat Linux
Classification: Retired
Component: ami (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Joo
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-03 22:59 EDT by Warren Togami
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-09-09 00:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-10-03 22:59:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When I run ami, nothing appears to happen although something appears in the
Gnome taskbar - the application didn't pop-up.  It is one of those rectangle
things with 2x2 hexadecimal numbers in them indicating that some charset or font
isn't working properly.

The actual application itself seems devoid of text, with several blank tabs.  I
can see radial button widgets, textboxs and a checkbox, but no text labels.

Version-Release number of selected component (if applicable):
RH 8.0
Tested on two systems, one with Korean language support installed, one without.
 Same results.

How reproducible:

Steps to Reproduce:
1. Run "ami"
Comment 1 David Joo 2002-10-04 00:47:16 EDT
Hi Warren..

Can you please post your /etc/sysconfig/i18n file please?

Also can you check whether ttfonts-ko file is installed?

Comment 2 Warren Togami 2002-10-04 01:09:41 EDT
It says the following when I run it from a console:

[root@laptop root]# ami

** WARNING **: fontset(*,*) loading failed

** WARNING **:
loading failed

** WARNING **: fontset(*,-*-*-medium-r-normal--16-*-*-*-c-*-*) loading failed

System #1 - without Korean chosen as an extra language during install
[root@laptop root]# cat /etc/sysconfig/i18n
ttfonts-ko is not installed

System #2 - with Korean chosen as an extra language during install
[root@ltspserver root]# cat /etc/sysconfig/i18n
ttfonts-ko is installed

It does work when you run it with "LANG=ko_KR ami", but it seems broken that its
display is completely messed up when you run it with LANG=en_US.UTF-8.
Comment 3 David Joo 2002-10-04 01:14:11 EDT
AMI is meant to work under LANG=ko_KR.
That is the only way at the moment.
But for the future, we will keep it in mind that it would be great to be able to
use the multiple language IM's on different LANG settings.

Thanks for the input!
Comment 4 Jens Petersen 2003-05-19 22:13:06 EDT
Re-openning since this now also affects ko_KR.UTF-8 in rawhide. ;-)

Probably the cleanest and best solution would be to change the locale
inside AMI to be ko_KR.eucKR internally.

An alternative would be to tweak "/etc/X11/xinit/xinitrc.d/xinput"
to run ami in ko_KR, but that wouldn't solve Warren's problem for
example of course.
Comment 5 Leon Ho 2003-08-05 00:19:01 EDT
Jens, i revisited the bug and thought it may related to the ordering of the
fontset. Tested against patches in 101377 and it works fine. Closing the bug
with duplicate of 101377.

*** This bug has been marked as a duplicate of 101377 ***

Note You need to log in before you can comment on or make changes to this bug.