Bug 101377 - changes the fontset order for CJK UTF-8 locale
changes the fontset order for CJK UTF-8 locale
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: XFree86 (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 75061 (view as bug list)
Depends On:
Blocks: 84593 90658 98520 CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-31 10:48 EDT by Akira TAGOH
Modified: 2007-04-18 12:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.3.0-25.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 06:50:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (10.37 KB, patch)
2003-07-31 10:49 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2003-07-31 10:48:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
The localized strings can't be displayed using the Core X window system fonts on
UTF-8 locale so that we don't have the complete ISO10646 fonts. the fontset
order which is written in XLC_LOCALE is basically prior ISO8859-1 rather than
ISO10646. but another legacy charsets are low priority.  So the ISO1646 must be
the lowest priority than other legacy charsets until we will get the full
supported ISO10646 font at least.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run the something like the localized X apps with UTF-8 locale.
2.
3.
    

Additional info:
Comment 1 Akira TAGOH 2003-07-31 10:49:38 EDT
Created attachment 93298 [details]
proposed patch
Comment 2 Akira TAGOH 2003-08-01 04:05:12 EDT
I've filed this bug to the upstream bugzilla: 
http://bugzilla.xfree86.org/show_bug.cgi?id=544
Comment 3 Leon Ho 2003-08-05 00:19:05 EDT
*** Bug 75061 has been marked as a duplicate of this bug. ***
Comment 4 Leon Ho 2003-08-06 20:59:57 EDT
Hi Mike, it is resolved in the upstream for now. Please apply it to Cambridge. 
Thanks! 
Comment 6 Mike A. Harris 2003-08-26 08:42:34 EDT
Adding bug dependancies based on email from Leon
Comment 7 Mike A. Harris 2003-09-04 06:50:30 EDT
Patch applied to XFree86-4.3.0-25.1 and later in rawhide.  Will be in Taroon
also soon.

Note You need to log in before you can comment on or make changes to this bug.