Bug 7507 - utmp/wtmp data not updated with Xwin terminal users
Summary: utmp/wtmp data not updated with Xwin terminal users
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: utempter
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact:
URL:
Whiteboard:
: 7543 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-12-02 14:05 UTC by hubbardr
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-28 22:22:28 UTC


Attachments (Terms of Use)

Description hubbardr 1999-12-02 14:05:00 UTC
Unable to see currently logged in users if they are on a Xwin terminal.
Console, telnet, and rsh'ed users are displayed. I have found this problem
on konsole, rxvt, Eterm, and gnome-terminal. Xterm is the only one that
logs users. Gnome-terminal allows the parameters --utmp and --wtmp to allow
the proper logging, the other terminals do not.

Comment 1 hubbardr 1999-12-02 14:13:59 UTC
Forgot to mention that I'm using last, w, and who.

Comment 2 Preston Brown 2000-02-28 22:22:59 UTC
the question of whether utmp/wtmp should be updated for a terminal window is a
long held and historic argument.  This behaviour is considered by some a bug, by
others not.

Comment 3 Preston Brown 2000-02-28 22:24:59 UTC
*** Bug 7543 has been marked as a duplicate of this bug. ***

Comment 4 David Balažic 2000-02-29 08:58:59 UTC
But should there not be at least a single entry for the X session ?
There is obviously someone logged in, but w/last/who suggests that there isn't
anyone.


Note You need to log in before you can comment on or make changes to this bug.