Bug 75070 - postfix does not show up in chkconfig --list
postfix does not show up in chkconfig --list
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: postfix (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
:
: 76100 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-03 23:25 EDT by Stephen John Smoogen
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-28 20:10:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2002-10-03 23:25:28 EDT
Description of Problem:


Found that certain utilities did not show up in a chkconfig --list, but were
installed and in /etc/init.d/. Postfix was one of these.

[root@glasya init.d]# rpm -qf postfix
postfix-1.1.11-5
[root@glasya init.d]# chkconfig --list postfix
service postfix supports chkconfig, but is not referenced in any runlevel (run
'chkconfig --add postfix')
[root@glasya init.d]# chkconfig --add postfix
[root@glasya init.d]# chkconfig --list postfix
postfix         0:off   1:off   2:on    3:on    4:on    5:on    6:off
Comment 1 Chris Ricker 2002-10-28 19:52:12 EST
*** Bug 76100 has been marked as a duplicate of this bug. ***
Comment 2 Chris Ricker 2002-10-28 20:10:45 EST
I don't think this is a bug, but rather supposed to be a "feature" of how
alternatives works....  My impression is that ntsysv / chkconfig / etc. only
display the service which is currently configured via alternatives.

if you have postfix and sendmail installed, one daemon will have a higher
priority than the other.  Whichever one is highest priority is the one which
should show up in chkconfig / ntsysv / etc.  Both should NOT show up there,
since if you have:

1.  both postfix and sendmail installed
2.  sendmail configured as the highest priority MTA
3.  run service postfix start

Bad Things happen (email gets lost, etc.), due to some components being postfix
and others being sendmail....

If you only have postfix installed, it should appear (and my recollection is
that it does).  If you have both postfix and sendmail installed, by default only
sendmail should appear (since it will be the default mta).  If you have both
installed and have run alternatives to make postfix the default, then only
postfix should appear (though I think currently both postfix and sendmail will
appear, which can lead to bad breakage).

Bill Nottingham is I think in charge of alternatives and therefore should know
for sure (which is why I've added him to the CC on this; hope he doesn't mind),
but that, at least, is my understanding of what's happening here, and why my
guess is that this is NOTABUG....
Comment 3 Bill Nottingham 2002-10-28 23:06:03 EST
Correct. the alternatives subsystem does chkconfig --del on the non-active services.

Note You need to log in before you can comment on or make changes to this bug.