Bug 750746 - This extesion is only working if a "user image" is selected.
This extesion is only working if a "user image" is selected.
Status: CLOSED DUPLICATE of bug 739271
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
16
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-02 05:54 EDT by Dietrich
Modified: 2011-11-02 07:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-02 07:05:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the .xsession-errors on crash. (8.16 KB, application/octet-stream)
2011-11-02 05:54 EDT, Dietrich
no flags Details

  None (edit)
Description Dietrich 2011-11-02 05:54:47 EDT
Created attachment 531300 [details]
the .xsession-errors on crash.

Description of problem:
on a fresh install installing and enabling the package gnome-shell-extension-alternative-status-menu results in the gnome-session crashing.

Version-Release number of selected component (if applicable):
recent

How reproducible:
allways when no "user image" is selected.

Steps to Reproduce:
1. fresh fedora install.
2. yum install gnome-shell-extension-alternative-status-menu
3. enable the extension using "advanced settings" (needs to be installed too)
4. log out and log in again.
5. observe the shell crashing.
  
Actual results:
The shell is crashing and one is asked to disable the extension on a fullscreen overlay. with the only option to log out.

Expected results:
add a working shutdown option.


Additional info:

A thing that I can imagine that causes this is some concurrency issue(My system has an SSD and a fast processor).
Another thing to note is that if the extension is enabled without restart it shows the working menu entry. only after logging out and in again the shell crashes.



General
=================================
UUID: 787399ba-ae7e-4250-892a-125ad06f861d
OS: Fedora release 16 (Verne)
Default run level: Unknown
Language: en_US.utf8
Platform: x86_64
BogoMIPS: 5346.14
CPU Vendor: GenuineIntel
CPU Model: Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
CPU Stepping: 5
CPU Family: 6
CPU Model Num: 26
Number of CPUs: 8
CPU Speed: 2668
System Memory: 5962
System Swap: 0
Vendor: System manufacturer
System: System Product Name System Version
Form factor: Desktop
Kernel: 3.1.0-5.fc16.x86_64
SELinux Enabled: 1
SELinux Policy: targeted
SELinux Enforce: Enforcing
MythTV Remote: Unknown
MythTV Role: Unknown
MythTV Theme: Unknown
MythTV Plugin: 
MythTV Tuner: -1


Devices
=================================
(32902:11299:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Thermal Control Registers
(32902:11298:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Rank Registers
(32902:13326:4163:33643) pci, pcieport, PCI/PCI, 5520/5500/X58 I/O Hub PCI Express Root Port 7
(4354:16385:4354:16) pci, firewire_ohci, FIREWIRE, SB Audigy FireWire Port
(32902:11329:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 QuickPath Architecture Generic Non-Core Registers
(32902:11265:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 QuickPath Architecture System Address Decoder
(32902:13317:4163:33643) pci, None, HOST/PCI, 5520/5500/X58 I/O Hub to ESI Port
(32902:11305:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Address Registers
(32902:13320:4163:33643) pci, pcieport, PCI/PCI, 5520/5500/X58 I/O Hub PCI Express Root Port 1
(32902:11280:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 QPI Link 0
(32902:11281:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 QPI Physical 0
(4523:17252:4163:33272) pci, sky2, ETHERNET, 88E8056 PCI-E Gigabit Ethernet Controller
(32902:14896:4163:33492) pci, i801_smbus, SERIAL, 82801JI (ICH10 Family) SMBus Controller
(32902:14880:4163:33492) pci, ata_piix, STORAGE, 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
(32902:14870:4163:33492) pci, None, PCI/ISA, 82801JIR (ICH10R) LPC Interface Controller
(32902:11292:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Test Registers
(32902:14886:4163:33492) pci, ata_piix, STORAGE, 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
(32902:14916:4163:33514) pci, pcieport, PCI/PCI, P6T DeLuxe Motherboard
(32902:9294:4163:33492) pci, None, PCI/PCI, 82801 PCI Bridge
(32902:14901:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #2
(32902:14900:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #1
(32902:14905:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #6
(32902:14902:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #3
(32902:11307:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Thermal Control Registers
(32902:14912:4163:33514) pci, pcieport, PCI/PCI, P6T DeLuxe Motherboard
(32902:14906:4163:33492) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #1
(32902:14908:4163:33492) pci, ehci_hcd, USB, 82801JI (ICH10 Family) USB2 EHCI Controller #2
(32902:13346:0:0) pci, None, 8259_INTERRUPT, 5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers
(32902:13358:0:0) pci, i7core_edac, 8259_INTERRUPT, 5520/5500/X58 I/O Hub System Management Registers
(32902:13368:0:0) pci, None, 8259_INTERRUPT, 5520/5500/X58 I/O Hub Throttle Registers
(32902:13347:0:0) pci, None, 8259_INTERRUPT, 5520/5500/X58 I/O Hub Control Status and RAS Registers
(32902:13322:4163:33643) pci, pcieport, PCI/PCI, 5520/5500/X58 I/O Hub PCI Express Root Port 3
(32902:14910:4163:33514) pci, snd_hda_intel, MULTIMEDIA, 82801JI (ICH10 Family) HD Audio Controller
(32902:14903:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #4
(32902:14904:4163:33492) pci, uhci_hcd, USB, 82801JI (ICH10 Family) USB UHCI Controller #5
(32902:14922:4163:33514) pci, pcieport, PCI/PCI, P6T DeLuxe Motherboard
(4354:4:4354:4099) pci, snd_emu10k1, MULTIMEDIA_AUDIO, SB Audigy
(32902:11297:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Address Registers
(4318:1507:0:0) pci, nouveau, VIDEO, GT200b [GeForce GTX 285]
(32902:11312:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Control Registers
(32902:11313:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Address Registers
(32902:11296:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Control Registers
(32902:11315:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Thermal Control Registers
(4358:12356:4358:12356) pci, firewire_ohci, FIREWIRE, VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller
(32902:11306:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Rank Registers
(32902:11289:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Target Address Decoder
(4523:17252:4163:33272) pci, sky2, ETHERNET, 88E8056 PCI-E Gigabit Ethernet Controller
(32902:11288:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller
(32902:11304:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Control Registers
(32902:11314:32902:32902) pci, None, HOST/PCI, Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Rank Registers


Filesystem Information
=================================
device mtpt type bsize frsize blocks bfree bavail file ffree favail
-------------------------------------------------------------------
/dev/sda1 / ext4 4096 4096 14423103 6434575 6288096 3670016 3104298 3104298
/dev/sdc4 WITHHELD fuseblk 4096 4096 453510933 34889823 34889823 140247420 139577953 139577953
/dev/sdc4 WITHHELD fuseblk 4096 4096 453510933 34889823 34889823 140247420 139577953 139577953
Comment 1 Dietrich 2011-11-02 05:58:24 EDT
same problem on ubuntu http://ubuntuforums.org/showthread.php?p=11362131
Comment 2 Mohamed El Morabity 2011-11-02 07:05:04 EDT

*** This bug has been marked as a duplicate of bug 739271 ***

Note You need to log in before you can comment on or make changes to this bug.