Bug 739271 - Alternative Status Menu extension crashes gnome-shell, can't login
Alternative Status Menu extension crashes gnome-shell, can't login
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
16
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
: 745453 748461 750746 751365 753086 753254 754793 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-17 00:00 EDT by Charles R. Anderson
Modified: 2011-12-12 18:11 EST (History)
32 users (show)

See Also:
Fixed In Version: gnome-shell-extensions-3.2.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-10 14:52:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 660520 None None None Never

  None (edit)
Description Charles R. Anderson 2011-09-17 00:00:34 EDT
Description of problem:

After an update (I believe to gnome-shell-3.1.91) Alternative Status Menu Extension causes gnome-shell to crash and pop up with the fail screen which offers to let you disable extensions.  Disabling just the Alternative Status Menu Extension allows login to proceed.

Version-Release number of selected component (if applicable):
gnome-shell-3.1.91-2.fc16.x86_64
gnome-shell-extension-alternative-status-menu-3.1.91-2.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1. Enable Alternative Status Menu Extension
2. Logout/Login
3. Fail screen appears
  
Actual results:

Fail screen appears.

Expected results:

Successful login.  No fail screen.  Alternative Status Menu shows up.

Additional info:

Other installed extensions:

gnome-shell-extension-alternate-tab-3.1.91-2.fc16.noarch
gnome-shell-extension-common-3.1.91-2.fc16.noarch
gnome-shell-extension-cpu-temperature-0-0.1.git712153f.fc16.noarch
gnome-shell-extension-places-menu-3.1.91-2.fc16.noarch
gnome-shell-extension-presentation-mode-0-0.2.gitc3ce6b2.fc16.noarch

Only enabled extensions when this issue happens:

Alternative Status Menu Extension
Places Status Indicator Extension
Comment 1 Ricardo Funke Ormieres 2011-10-08 17:23:52 EDT
Same here,

I have just alternative-status-menu installed.
Comment 2 Mohamed El Morabity 2011-10-12 08:50:14 EDT
*** Bug 745453 has been marked as a duplicate of this bug. ***
Comment 3 Mohamed El Morabity 2011-10-12 08:53:23 EDT
It's not a surprise, it was already announced in the update release notes:
   https://admin.fedoraproject.org/updates/FEDORA-2011-13770
Bug already reported upstream:
   https://bugzilla.gnome.org/show_bug.cgi?id=660520
Comment 4 Mohamed El Morabity 2011-10-24 11:11:21 EDT
*** Bug 748461 has been marked as a duplicate of this bug. ***
Comment 5 Mohamed El Morabity 2011-11-02 07:05:05 EDT
*** Bug 750746 has been marked as a duplicate of this bug. ***
Comment 6 Dietrich 2011-11-02 07:12:29 EDT
For those interested to getting things working: just select a "user image".
Comment 7 Mohamed El Morabity 2011-11-04 14:14:11 EDT
*** Bug 751365 has been marked as a duplicate of this bug. ***
Comment 8 Jason Farrell 2011-11-09 13:41:20 EST
Bit me here.

I rely on this extension as the keyboard is physically covered on the kid's laptop (to prevent broken keys) so I can't easily hold down the ALT key to properly shutdown.
Comment 9 Jason Farrell 2011-11-09 13:50:31 EST
Setting a user image worked as a workaround. Thanks Dietrich (comment #6)
Comment 10 Mohamed El Morabity 2011-11-11 05:10:39 EST
*** Bug 753086 has been marked as a duplicate of this bug. ***
Comment 11 Sam Varshavchik 2011-11-12 10:16:58 EST
This bug is still present in gnome-shell-extension-alternative-status-menu-3.2.0-1.fc16.noarch.

Workaround still works.
Comment 12 Mohamed El Morabity 2011-11-17 13:43:11 EST
*** Bug 754793 has been marked as a duplicate of this bug. ***
Comment 13 kksheth 2011-11-18 02:10:25 EST
bug still there in fc16_64 bit as on 18,Nov,2011. (duly updated).

Workout of adding user image works.
Comment 14 jrh 2011-11-18 02:27:38 EST
Bug still reproduces with 
gnome-shell-extension-alternative-status-menu-3.2.0-2.fc16.noarch.
Comment 15 jrh 2011-11-18 02:49:41 EST
Could someone help me find the workaround. What you mean above: select a "user image"?
Select from where?
Thanks.
Comment 16 Ricardo Funke Ormieres 2011-11-18 06:36:30 EST
(In reply to comment #15)
> Could someone help me find the workaround. What you mean above: select a "user
> image"?
> Select from where?
> Thanks.

Select an image for your user, click in your username at the top right of your screen, then click in the image square to select an image for you user.

;)
Comment 17 jrh 2011-11-18 09:07:19 EST
Nice workaround indeed - and it works!
Thanks:)
Comment 18 Andre Robatino 2011-11-24 21:10:43 EST
Just a warning, it appears that once you select a non-default picture, you can't go back to the original one, even though the picture selection GUI makes it look like you could. Of the 25 pictures in the 5x5 grid, 24 are in /usr/share/pixmaps/faces, and the remaining generic icon can't be selected. Is this a known bug, and if not, what component should it be filed against?
Comment 19 Flurin Rindisbacher 2011-11-25 12:56:07 EST
subscribing to this bug...
Comment 20 Andre Robatino 2011-11-25 20:37:55 EST
Filed bug 757257 against control-center for not being able to return to no user image.
Comment 21 Jonathan Burgess 2011-11-27 17:19:23 EST
The problem also exists on an i686 machine.
I have the following.
Name        : gnome-shell-extension-alternative-status-menu
Arch        : noarch
Version     : 3.2.0

Name        : gnome-shell
Arch        : i686
Version     : 3.2.1

with this OS information: 3.1.2-1.fc16.i686.PAE
Comment 22 Robin Parriath 2011-11-29 12:01:23 EST
Suggested workaround doesn't work for me.  Fail screen appears at login/gnome-shell restart even with the user image selected.

I'm running the following:

Kernel      : 3.1.2-1.fc16.x86_64

Gnome Shell : gnome-shell.x86_64
              3.2.1-2.fc16

Extension   : gnome-shell-extension-alternative-status-menu.noarch
              3.2.0-2.fc16
Comment 23 Fedora Update System 2011-11-29 20:38:26 EST
gnome-shell-extensions-3.2.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.2.1-1.fc16
Comment 24 Andre Robatino 2011-11-29 21:12:47 EST
Too bad I won't be able to test the fix, since it's impossible for me to go back to no user image (bug 757257).
Comment 25 Andre Robatino 2011-11-30 00:26:19 EST
After applying the accountsservice update in bug 757257, was able to get back to the default user image and test this update, and it does appear to fix the bug.
Comment 26 Mohamed El Morabity 2011-11-30 12:37:23 EST
*** Bug 753254 has been marked as a duplicate of this bug. ***
Comment 27 Daniele Viganò 2011-11-30 16:41:01 EST
Still having the issue (crash at login):

yum info gnome-shell-extension-alternative-status-menu

Installed Packages
Name        : gnome-shell-extension-alternative-status-menu
Arch        : noarch
Version     : 3.2.0
Release     : 2.fc16
Comment 28 Mohamed El Morabity 2011-11-30 17:42:56 EST
(In reply to comment #27)
> Still having the issue (crash at login):
> 
> yum info gnome-shell-extension-alternative-status-menu
> 
> Installed Packages
> Name        : gnome-shell-extension-alternative-status-menu
> Arch        : noarch
> Version     : 3.2.0
> Release     : 2.fc16
Please try the latest version 3.2.1, in updates-testing repo.
Comment 29 Benny 2011-11-30 18:07:14 EST
yum --enablerepo=updates-testing update gnome-shell-extension-alternative-status-menu
...
Setting up Update Process
No Packages marked for Update

yum info gnome-shell-extension-alternative-status-menu
...
Installed Packages
Name        : gnome-shell-extension-alternative-status-menu
Arch        : noarch
Version     : 3.2.0
Release     : 2.fc16
...

Wasn't the new package pushed on the updates-testing repo or am I messing things up?
Comment 30 Mohamed El Morabity 2011-11-30 18:17:23 EST
(In reply to comment #29)
> Wasn't the new package pushed on the updates-testing repo or am I messing
> things up?
It is still in pending status, indeed, sorry for having written my previous message too fast. You can test the updated packages from their Koji page:
   http://koji.fedoraproject.org/koji/buildinfo?buildID=276388
Comment 31 Jonathan Burgess 2011-12-01 21:13:12 EST
(In reply to comment #30)
> (In reply to comment #29)
> > Wasn't the new package pushed on the updates-testing repo or am I messing
> > things up?
> It is still in pending status, indeed, sorry for having written my previous
> message too fast. You can test the updated packages from their Koji page:
>    http://koji.fedoraproject.org/koji/buildinfo?buildID=276388

I tested the koji packages, and the "Power Off" menu item doesn't appear until 6 or 7 seconds after the rest of the desktop environment has loaded. While it is non-critical, I would still consider it a bug.
Comment 32 Andre Robatino 2011-12-01 21:18:02 EST
I noticed that too, but couldn't be sure if it's different from previous behavior, since I don't normally bring up the User Menu immediately after logging in.
Comment 33 Mohamed El Morabity 2011-12-01 21:21:25 EST
> I tested the koji packages, and the "Power Off" menu item doesn't appear until
> 6 or 7 seconds after the rest of the desktop environment has loaded. While it
> is non-critical, I would still consider it a bug.
This *is* the fix. The crash is due to a race condition. To avoid it, a delay has been added in the update to load the extension after 10 seconds.
Comment 34 Jonathan Burgess 2011-12-01 21:38:33 EST
(In reply to comment #32)
> I noticed that too, but couldn't be sure if it's different from previous
> behavior, since I don't normally bring up the User Menu immediately after
> logging in.

That is just my definition of testing.

(In reply to comment #33)
> This *is* the fix. The crash is due to a race condition. To avoid it, a delay
> has been added in the update to load the extension after 10 seconds.
I see. Forgive my naivete, but is there not some type of queue system that the extensions are loaded in? This is good for this extension, but if this happens in the future with other extensions, then each extension would have to have a unique delay programmmed into it, right?
Comment 35 Dietrich 2011-12-02 05:11:56 EST
(In reply to comment #33)
> > I tested the koji packages, and the "Power Off" menu item doesn't appear until
> > 6 or 7 seconds after the rest of the desktop environment has loaded. While it
> > is non-critical, I would still consider it a bug.
> This *is* the fix. The crash is due to a race condition. To avoid it, a delay
> has been added in the update to load the extension after 10 seconds.

I'd rather not consider a delay as a fix. This is a workaround not a fix. To fix the problem you have to check if something is available. If it is not available wait until it is available (not a fixed amount of time)!
Comment 36 Mohamed El Morabity 2011-12-02 05:24:15 EST
> I'd rather not consider a delay as a fix. This is a workaround not a fix. To
> fix the problem you have to check if something is available. If it is not
> available wait until it is available (not a fixed amount of time)!
Patches are welcome, as usual.
Comment 37 Fedora Update System 2011-12-02 16:34:25 EST
Package gnome-shell-extensions-3.2.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extensions-3.2.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16656/gnome-shell-extensions-3.2.1-1.fc16
then log in and leave karma (feedback).
Comment 38 Fedora Update System 2011-12-10 14:52:08 EST
gnome-shell-extensions-3.2.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 39 Michael Adeyeye 2011-12-12 17:34:10 EST
The hibernate and power off options does not appear when the extension is installed on fedora 16. Power off appears only when the alt button is pressed.

I installed gnome-shell-extensions-3.2.1-1.fc16
Comment 40 Michael Adeyeye 2011-12-12 17:35:04 EST
The hibernate and power off options "do" not appear when the extension is
installed on fedora 16. Power off appears only when the alt button is pressed.

I installed gnome-shell-extensions-3.2.1-1.fc16
Comment 41 Flurin Rindisbacher 2011-12-12 18:11:13 EST
(In reply to comment #40)
> The hibernate and power off options "do" not appear when the extension is
> installed on fedora 16. Power off appears only when the alt button is pressed.
> 
> I installed gnome-shell-extensions-3.2.1-1.fc16

did you enable the extension using gnome-tweak-tool? for me it's working now.

Note You need to log in before you can comment on or make changes to this bug.