Bug 75080 - Installer halts with an error message about KeyError: kernel-smp
Installer halts with an error message about KeyError: kernel-smp
Status: CLOSED DUPLICATE of bug 75105
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 01:54 EDT by Nathan M
Modified: 2007-03-26 23:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-04 01:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Complete error report dump saved from installer (124.26 KB, text/plain)
2002-10-04 01:56 EDT, Nathan M
no flags Details

  None (edit)
Description Nathan M 2002-10-04 01:54:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461; Hotbar 
4.1.5.0; .NET CLR 1.0.3705)

Description of problem:
The installer works just fine once I hit upgrade option and continue to the 
point where it is reading packages list. Then a error message popups up with 
debug info of some script and complaining about KeyError: kernel-smp. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Requirements: You must already have redhat linux installed(7.2 or 7.3) with 
kernel-smp as the kernel and not the other kind. (On a side note I use a raid 
card that will not function without the smp kernel and because of that I am 
forced to use a smp kernel instead of the other kernel since the other does not 
work at all with my raid card.)
 
1. Place CD-1 of Redhat Linux 8 into CD-Drive and boot off of it
2. Begin install and select upgrade OS
3. Now attemp to complete the installation after it's done reading packages.
	

Actual Results:  The installer popups an error message with the contents that 
are displayed in Additional Information field.

Expected Results:  It should have continued installation without any errors nor 
problems.

Additional info:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 694, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 446, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 349, in upgradeFindPackages
    id.hdList[package[rpm.RPMTAG_NAME]].select()
  File "/usr/lib/anaconda/comps.py", line 171, in __getitem__
    return self.packages[item]
KeyError: kernel-smp

Local variables in innermost frame:
item: kernel-smp
self: <comps.HeaderListFromFile instance at 0x82afe34>


(I also have a complete dump of the error that I saved on a disk since it 
recommended me to do so)
Comment 1 Nathan M 2002-10-04 01:56:17 EDT
Created attachment 78544 [details]
Complete error report dump saved from installer
Comment 2 Michael Fulbright 2002-10-04 11:58:19 EDT
This error occurred because you have the kernel-smp package installed on your
system but we no longer ship a smp kernel for the processor in your system.

You can continue the upgrade (but w/o smp support) by removing the kernel-smp
package and proceeding.



*** This bug has been marked as a duplicate of 75105 ***
Comment 3 Nathan M 2002-10-04 17:31:52 EDT
Did you not see my note? The fact that my hardware will NOT boot off of the non-
smp kernel type! Well thanks Redhat for screwing me over.
Comment 4 Jesse Keating 2002-10-11 02:32:39 EDT
To clarify, the hardware in your system is of i586 in nature, and Red Hat no
longer ships a i586 SMP kernel, only i686 and Athlon.  Please do not interpret
comments in this bug as "Red Hat doesn't support multiprocessor machines"
Comment 5 Nathan M 2002-10-11 09:23:11 EDT
OMG only i686 machines? That's also killing Duron AMD CPUs which my main 
machine uses. You mind as not support smp kernels at all if you guys are going 
to be that narrow in what you support.

Note You need to log in before you can comment on or make changes to this bug.