This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 750956 - Long strings slow down the operation
Long strings slow down the operation
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Performance (Show other bugs)
1.4.1
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alex Eng
David Mason
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-11-02 21:00 EDT by Yuko Katabami
Modified: 2012-03-06 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2011-11-02 21:00:26 EDT
Description of problem:
When I work with long strings, the interface slows down significantly.
It is causing a productivity issue.

Version-Release number of selected component (if applicable):
1.4.1

How reproducible:
Always

Steps to Reproduce:
1. Open Zanata file with long strings (approx. more than 15 lines)
2.
3.
  
Actual results:
Slows down typing

Expected results:
Should be the normal speed

Additional info:
Comment 3 Hedda Peters 2012-02-08 23:35:25 EST
Happening to me a lot, too, strings of only ~10 lines are enough to slow down the performance considerably.

Happens in all files on translate.engineering I'm working on these days, a good example with plenty of long strings can be found here: https://translate.engineering.redhat.com/webtrans/Application.html?project=rhel_deployment_guide&iteration=6.2&localeId=de&locale=de# (Deployment Guide, file Package_Kit)

Gedit is my friend at the moment - I am forced to copy and paste my translation into the editor for a huge part of the messages in any given file - this not only slows down my productivity, but also means that all editor features like the translation memory are effectively worthless as I'm not using the editor at all for those strings.

Is this issue being adressed?
The original report was for 1.4.1, I am encountering it for Zanata version 1.4.5-alpha-1 (20120124-0107) on F16, using FF 9.0.1

Thanks
Comment 4 David Mason 2012-02-10 00:30:02 EST
Note: This appears to be caused by the key shortcut implementation - disabling the key shortcut code for the editor allows extremely long strings (over 30 lines) to be edited without a noticeable delay in Firefox 3.6.18. There also appears to be some legacy undo/redo code that isn't properly disabled.
Comment 5 Alex Eng 2012-02-12 18:34:56 EST
This caused by the autosize function on the textArea while input. This bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=773510
Comment 7 David Mason 2012-02-20 20:29:31 EST
Verified in 1.5 with Firefox 3.6.18 and Chrome 14.0.835.186

Note You need to log in before you can comment on or make changes to this bug.