Bug 773510 - workspace quivers when translation of last message gets too long
workspace quivers when translation of last message gets too long
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.4.3-SNAPSHOT
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Alex Eng
David Mason
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2012-01-11 23:22 EST by Hedda Peters
Modified: 2012-03-06 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:06:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-01-11 23:22:03 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.24) Gecko/20111108 Fedora/3.6.24-1.fc14 Firefox/3.6.24

If the translation of the last message on any give page is long (more than ~5 lines), the whole workspace will constantly jump up and down a bit (as in, the scroll bar is juming up and down) with every typed letter. The longer the message, the worse it gets.
In older Zanata versions it was entirely impossible to display those last lines of a long, last message. Now it is possible, but the view sort of quivers before your eyes, making it hard to focus.

Reproducible: Always

Steps to Reproduce:
1. Open workspace for any document
2. Open very last message on any given page
3. Enter a translation that is longer than ~5 lines.
Actual Results:  
Workspace should give a steady view

Expected Results:  
Workspace quivers when scroll bar jumps up and down in order to keep up with the longer message
Comment 1 Alex Eng 2012-02-12 18:35:09 EST
This caused by the autosize function on the textArea while input. This bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=750956
Comment 3 David Mason 2012-02-20 20:29:14 EST
Verified in 1.5 with Firefox 3.6.18 and Chrome 14.0.835.186

Note You need to log in before you can comment on or make changes to this bug.