Bug 75111 - No audio programs work
No audio programs work
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Depends On:
  Show dependency treegraph
Reported: 2002-10-04 12:19 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-04 12:19:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
XMMS will not load playlist.  XMMS will not play any audio.  Tried all the other
built in audio players and all have the same problem.  All these programs worked
fine before installing 8.0.  I installed clean after my system was angry about
an upgrade from 7.3 due to Ximian installs.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Start any audio program
2.Try to play music

Actual Results:  No audio output.  If I load a playlist, it just flies through
the list and stops.  I remember seeing this before and  just reinstalled xmms to
fix.  But this looks like a sound server problem?

Expected Results:  Music plays

Additional info:
Comment 1 Bill Nottingham 2002-10-04 13:02:09 EDT

*** This bug has been marked as a duplicate of 74632 ***
Comment 2 Need Real Name 2002-10-04 13:57:17 EDT
I still get no audio output from any type of music files.
I can do a detect sound card, and hear the music, but it seems that none of my
system sounds are working either.  I enabled them from the control panel(gnome)
but can't hear anything.  XMMS does think it is playing music, so am I missing
Comment 3 Bill Nottingham 2002-10-04 15:08:59 EDT
OK, what sort of files are you playing, and what is the *exact* behavior. Does
it play at normal speed, with the normal animation, but no sound? Does it just
skip the file?
Comment 4 Need Real Name 2002-10-04 15:26:13 EDT
I used a CD and it played at normal speed with no sound output.
Comment 5 Bill Nottingham 2002-10-04 15:29:51 EDT
And this worked ok on 7.3 in the same machine?

Hm, is the mixer turned up, and is the sound driver loaded?
Comment 6 Need Real Name 2002-10-04 16:33:37 EDT

This worked on 7.3
I have the mixer in the panel and it is all the way up. I am not positive that
the sound driver loaded, but when I do System Settings->Sound Card Detection It
shows up as module I810_audio, and the test sound works fine.
Comment 7 Brian Baggett 2002-10-23 14:37:22 EDT
This problem is specific to kernel 2.4.18-17.8.0.  Once loaded, no audio
applications work.  Removing kernel 2.4.18-17.8.0 and reverting back to
2.4.18-14, sound works.
Comment 8 Need Real Name 2002-10-23 15:09:19 EDT
I didn't upgrade the kernel until after reporting this problem.  Do you still
want me to go back to 18-14?
Comment 9 Brian Baggett 2002-10-23 16:21:13 EDT
Re: 2.4.18-17.8.0 and no sound:  This affects my laptp with its ESS ES1983S
Maestro-3i PCI soundcard using the maestro3 driver, but not my workstation with
a Creative SB LIVE! that uses the emu10k1 driver.
Comment 10 Bugzilla owner 2004-09-30 11:39:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.