Bug 74632 - xmms does not include mp3 support on rh8.0
xmms does not include mp3 support on rh8.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 74754 74789 75629 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-27 20:12 EDT by Need Real Name
Modified: 2014-03-16 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-27 20:12:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-27 20:12:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
i know it's not a bug
but xmms should really get back support for mp3
what's the use for xmms otherwise?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.xmms
2.choose mp3 file
3.it's not shown in the playlist
	

Additional info:
Comment 1 Bill Nottingham 2002-09-30 16:17:57 EDT
See the release notes for explanation.
Comment 2 Bill Nottingham 2002-10-01 12:33:53 EDT
*** Bug 74754 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2002-10-01 13:46:40 EDT
*** Bug 74789 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2002-10-01 13:47:37 EDT
 o Due to patent licensing, and conflicts between such patent licenses
   and the licenses of application source code, MPEG-1/2 audio layer 3
   (mp3) support has been removed from applications in Red Hat Linux such
   as XMMS and noatun. Red Hat suggests the use of Ogg Vorbis(TM), an
   open, non-proprietary, patent-and-royalty-free compressed audio
   format.
Comment 5 Bill Nottingham 2002-10-04 13:02:02 EDT
*** Bug 75111 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2002-10-10 12:56:25 EDT
*** Bug 75629 has been marked as a duplicate of this bug. ***
Comment 7 Mike Hearn 2003-01-07 15:05:20 EST
Considering that there has been plenty of time for the MP3 licensing scenario to
be resolved by now, I'm surprised to see that Phoebe still does not include it,
despite the fact that the first thing large numbers of users do is go to
xmms.org and get the RPM to add support back in. None of the other distros seem
concerned by this, and as far as I'm aware, Thompson/Fraunhofer have not said
Free decoders are against their licensing. Is there still a solid legal reason
behind not including this? I ask because as somebody who does free tech support
on irc://irc.freenode.net/#linuxhelp, this is a question that crops up regularly.
Comment 8 Bill Nottingham 2003-01-07 15:18:09 EST
The situation has not changed at all. The licensing for the patent still
conflicts with the GPL.

Note You need to log in before you can comment on or make changes to this bug.