Bug 751264 - Search in Translation Editor: Ghost content appears on 1st result when click on 2nd to last result.
Search in Translation Editor: Ghost content appears on 1st result when click ...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.5-SNAPSHOT
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks: Zanata-1.4.3
  Show dependency treegraph
 
Reported: 2011-11-04 01:00 EDT by Ding-Yi Chen
Modified: 2012-04-23 00:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 755799 (view as bug list)
Environment:
Last Closed: 2012-04-23 00:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2011-11-04 01:00:14 EDT
Description of problem:
On searching a string in translation editor, 
when clicking on 2nd, 3rd .., or last result, the Ghost content, apparently the translation of first entry, is "pasted" on 1st result.

Version-Release number of selected component (if applicable):
Zanata version 1.5-SNAPSHOT (20111027-1415)

How reproducible:
Always

Steps to Reproduce:
1. Visit project IBusChewing, version master, language zh-Hans, document ibus-chewing.
2. Now should be at message view. Type "disable" in search field.
3. Click on the 3rd result.
  
Actual results:
"无缺省值,略去。", came from the 1st entry of the document, suddenly appear in the 1st result.

Expected results:
1st result should be remain empty.

Additional info:
This bug only appear in 1.5, but not 1.4.
Comment 1 Alex Eng 2011-11-08 16:25:05 EST
Problem appears in 1.4 as well.
Comment 2 Alex Eng 2011-11-08 19:31:31 EST
Problem occurs due to the "Enter" key capturing. Problem occurs only in 1.5 branch.
Comment 3 Alex Eng 2011-11-08 20:05:17 EST
Problem fixed in 1.5 branch. See https://github.com/zanata/zanata/commit/a97b026b69bccb34f463a95b1b1cd5dbfcade82d
Comment 4 Alex Eng 2011-11-11 00:40:51 EST
Problem found in 1.4 as well. 
See https://github.com/zanata/zanata/commit/c949db8dc17ebf2078d36d9867833a3b3692fd68 for fix in 1.4
Comment 5 Alex Eng 2011-11-22 00:36:38 EST
Duplication of this bug: 755799
Comment 6 Ding-Yi Chen 2011-11-29 00:59:17 EST
Actually 755799 contains two issues:
One is this bug, and another is failed to displayed the translated content on row 2, 3, ...
Comment 7 Ding-Yi Chen 2011-11-29 01:04:09 EST
VERIFIED with:

Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1300)
Zanata version 1.5-SNAPSHOT (20111129-0927)

Note You need to log in before you can comment on or make changes to this bug.