Bug 755799 - Existing translation of search results are not displayed
Summary: Existing translation of search results are not displayed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-UI
Version: 1.4.2
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Runa Bhattacharjee
QA Contact: Ding-Yi Chen
URL: https://translate.zanata.org/zanata/w...
Whiteboard:
Depends On:
Blocks: Zanata-1.4.3
TreeView+ depends on / blocked
 
Reported: 2011-11-22 04:47 UTC by Hedda Peters
Modified: 2013-03-04 02:22 UTC (History)
3 users (show)

Fixed In Version: 1.4.3-alpha-3-SNAPSHOT (20111128-1320)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 751264
Environment:
Last Closed: 2012-04-23 04:32:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 751264 None None None Never

Internal Links: 751264

Description Hedda Peters 2011-11-22 04:47:27 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.24) Gecko/20111108 Fedora/3.6.24-1.fc14 Firefox/3.6.24

When using the search functionality to find certain messages within one file, the filter correctly only shows messages that contain the string with matches. However, all displayed strings appear untranslated, even though some are translated. Only when clicking into the individual messages, the translation will appear. When closing editor, the translation disappears again.

On the other hand, the very first message of those search results displays a translation, which is not correct, and when clicking into the first message, this translation disappears/correct translation is displayed. When closing editor for first message, wrong translation appears again

Reproducible: Always

Steps to Reproduce:
1. Open translation workspace
2. Enter search term into the search box at top right
3. Hit enter
Actual Results:  
Search results show empty messages in the msgtr field, and show non-existing translation in first message

Expected Results:  
Search results should show existing translation correctly.

Right now it seems to happen consistently every time. However, this is the fist time I'm noticing it... 
With this bug the search functionality is rather useless/hard to use right now.

Comment 1 Alex Eng 2011-11-22 05:25:26 UTC
Duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=751264. In QA status

Comment 2 Hedda Peters 2011-11-22 05:57:39 UTC
Just to be sure:

https://bugzilla.redhat.com/show_bug.cgi?id=751264 is only mentioning the ghost content of the first string though - not the disappearing act of the rest of strings 2 - n in the search results.

Comment 3 Ding-Yi Chen 2011-11-30 04:25:22 UTC
VERIFIED with Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1320)
Zanata version 1.5-SNAPSHOT (20111129-0927)


Note You need to log in before you can comment on or make changes to this bug.