Bug 751290 - [kde] LibreOffice has black on dark-grey tooltip-texts
[kde] LibreOffice has black on dark-grey tooltip-texts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
: 755512 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-04 04:34 EDT by Marc Muehlfeld
Modified: 2015-07-13 13:35 EDT (History)
19 users (show)

See Also:
Fixed In Version: libreoffice-3.4.4.2-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-29 20:54:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of a tooltip-text (48.66 KB, image/png)
2011-11-04 04:34 EDT, Marc Muehlfeld
no flags Details
Eclipse (63.02 KB, image/png)
2011-11-23 12:12 EST, Germano Massullo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 283572 None None None Never
FreeDesktop.org 40461 None None None Never

  None (edit)
Description Marc Muehlfeld 2011-11-04 04:34:52 EDT
Created attachment 531722 [details]
Screenshot of a tooltip-text

Description of problem:
In LibreOffice all tooltip-texts appear in black colour on a dark-grey background, what makes it almost impossible to read.


Version-Release number of selected component (if applicable):
3.4.3.2-15


How reproducible:
Always. In all LO applications.


Steps to Reproduce:
1. Open a LibreOffice application
2. Point with your mouse to an icon and wait until the tooltip-text is displayed.


Actual results:
Tooltip-texts in black colour on dark-grey background. (see attached screenshot).


Expected results:
Background colour of tooltip text should be a light colour, so that it is readable.


Additional info:
The tooltip-texts in LO on F15 where fine.
Comment 1 David Tardon 2011-11-04 05:23:23 EDT
KDE-only problem
Comment 2 David Tardon 2011-11-21 06:28:44 EST
*** Bug 755512 has been marked as a duplicate of this bug. ***
Comment 3 Rex Dieter 2011-11-21 14:40:17 EST
Seems only our default kde "Oxygen" color scheme triggers this as well.  All other schemes seem ok. :(

Seeing similar oddness in digikam tooltips as well, there's probably a connection.

I'll dig into it more tomorrow.
Comment 4 Rex Dieter 2011-11-21 16:35:35 EST
I think I found the change in Oxygen.colors that's the culprit,

https://projects.kde.org/projects/kde/kde-workspace/repository/revisions/602a3c2c9e0cb2a32184139adfd2fa1dcf712aeb

[Colors:Tooltip] BackgroundNormal and ForegroundNormal look wrong, (swapped?).

see also similar digikam issue,
https://bugs.kde.org/show_bug.cgi?id=283572

I'm going to swap these back, at least until we get some feedback from oxygen upstream.
Comment 5 Rex Dieter 2011-11-21 17:03:18 EST
OK, #oxygen replied with some helpful advice, and that this is indeed almost certainly an application bug,
"Applications should render QPalette::ToolTipText on QPalette::ToolTipBase if
they only support QPalette. Applications that support KColorScheme can use the
additional roles valid for the tool tip's background."

I think we have a fix for digikam, I can look into this next (or Lukas given we have a hint what to look for now).
Comment 6 Martin Kho 2011-11-22 12:00:34 EST
Hi,

FYI: for the time being one can set the OOO_FORCE_DESKTOP=gnome environment variable in ~/.bash_profile. You'll get tooltips black on blue (like e.g. in Firefox).

Hope this helps,

Martin Kho
Comment 7 Jonathan Ryshpan 2011-11-22 17:32:38 EST
(In reply to comment #6)
> FYI: for the time being one can set the OOO_FORCE_DESKTOP=gnome environment
> variable in ~/.bash_profile. You'll get tooltips black on blue (like e.g. in
> Firefox).
> 
> Hope this helps,

It does help.  Tips are now readable.

BTW: As expected, this problem also occurs on KDE running on an x86_64 system running Fedora-16.
Comment 8 Kevin Kofler 2011-11-23 09:54:22 EST
OOO_FORCE_DESKTOP=gnome is a crude workaround which disables all KDE integration (and enables the GNOME one instead), not a fix!

The real issue was actually fixed in upstream LibreOffice, I think there will be a Fedora update for this shortly.
Comment 10 Martin Kho 2011-11-23 10:15:05 EST
Hi Kevin,

Sure my comment was absolutely not meant to be a fix! More a very temporary
workaround as long as no fix was available. Some bugs can live really long
(e.g. Amarok's high cpu usage) ;-) It's nice to see that upstream has already
fixed this issue.

Thanks,

Martin Kho
Comment 11 Fedora Update System 2011-11-23 10:40:12 EST
libreoffice-3.4.4.2-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libreoffice-3.4.4.2-3.fc16
Comment 12 Germano Massullo 2011-11-23 12:02:20 EST
Since Fedora 15. a similar problems happens in Eclipse. Could it be related? See attachment
Comment 13 Rex Dieter 2011-11-23 12:08:14 EST
eclipse has no native kde integration that I'm aware of, but either way, it's an appliation-specific (ie, eclipse) bug.
Comment 14 Kevin Kofler 2011-11-23 12:08:32 EST
It's definitely not the same bug (this one is in LibreOffice code), please file a separate bug.
Comment 15 Germano Massullo 2011-11-23 12:12:00 EST
Created attachment 535564 [details]
Eclipse
Comment 16 nucleo 2011-11-23 12:12:39 EST
This (and digikam) bug first appeared with changed in KDE 4.7 Oxygen colors.
Fedora 15 have KDE 4.6 so this bug can't be there.
Comment 17 Kevin Kofler 2011-11-23 12:26:39 EST
It can if he's using the kde47 repo, but this looks like a different bug to me (the background is really black and not almost black). Please file a separate bug against Eclipse. (As I wrote, it'd have to be fixed separately in any case. But the Eclipse issue doesn't look related to the Oxygen color scheme change at all.)
Comment 18 Kevin Kofler 2011-11-23 12:33:55 EST
The Eclipse issue is now bug #756467, please post any further comments about Eclipse there.
Comment 19 Fedora Update System 2011-11-23 18:31:25 EST
Package libreoffice-3.4.4.2-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.4.4.2-3.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16330/libreoffice-3.4.4.2-3.fc16
then log in and leave karma (feedback).
Comment 20 Kevin Kofler 2011-11-24 03:42:29 EST
Uhm, this is still in updates-testing, no idea why Bodhi decided to reset the status to MODIFIED, I'm setting it back to ON_QA.
Comment 21 Martin Kho 2011-11-24 08:43:13 EST
Hi,

Just updated Libreoffice and it's indeed much nicer to have the KDE theme colours :-)

Thanks,

Martin Kho
Comment 22 Fedora Update System 2011-11-29 20:54:52 EST
libreoffice-3.4.4.2-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.