Bug 751376 - magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (SemaphoreInfo *)
Summary: magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (Sema...
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: php-pecl-gmagick
Version: el6
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pavel Alexeev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 808674 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-04 14:24 UTC by Jan ONDREJ
Modified: 2012-04-12 03:15 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-03-25 22:27:23 UTC


Attachments (Terms of Use)
Problematic image (1.23 KB, image/svg+xml)
2012-03-14 09:48 UTC, Jan ONDREJ
no flags Details
GDB output (4.07 KB, text/plain)
2012-03-18 06:21 UTC, Jan ONDREJ
no flags Details

Description Jan ONDREJ 2011-11-04 14:24:08 UTC
Description of problem:
Using Gmagick() function from php it's failing on this error.

Version-Release number of selected component (if applicable):
GraphicsMagick-1.3.12-1.el6.x86_64
php-pecl-gmagick-1.0.2b1-3.el6.x86_64

How reproducible:
always

 
Actual results:
[Fri Nov 04 14:43:17 2011] [notice] child pid 9962 exit signal Aborted (6)
httpd: magick/semaphore.c:525: LockSemaphoreInfo: Assertion `semaphore_info != (
SemaphoreInfo *) ((void *)0)' failed.

Expected results:
no error

Additional info:
Here is my failing php script:
<?php
$gm = new Gmagick();
$gm = new Gmagick('test.jpg');

I am not sure, if this was already applied:
http://sourceforge.net/tracker/index.php?func=detail&aid=3136111&group_id=118983&atid=682742

Comment 1 Rex Dieter 2011-11-04 14:52:45 UTC
OK, seems php-pecl-gmagick needs fixing by the looks of it

Probably add a call to:

* InitializeMagick() MUST be invoked prior to using any Magick API
function. Failure to do so will likely lead to an immediate
application crash. This is due to initialization and runtime
changes intended to improve thread safety and efficiency.
Previously it was only strongly recommended to invoke
InitializeMagick().

Comment 2 Pavel Alexeev 2011-11-06 11:14:27 UTC
Thank you for your bugreport and willing make free software better!

Reported upstream: https://bugs.php.net/bug.php?id=60229

We close bug now, as it related to upstream developing. But we continue track changes and whatever it will be fixed ve consider make update in Fedora.

Comment 3 Jan ONDREJ 2012-03-09 08:52:17 UTC
Looks like it's now fixed in Fedora, but still present in EPEL6.
Please, can you rebuild EPEL packages to upstream version (or at least Fedora's version)?

Comment 4 Fedora Update System 2012-03-10 13:26:30 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/php-pecl-gmagick-1.1.0-0.2.RC2.el5

Comment 5 Fedora Update System 2012-03-10 13:36:24 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-pecl-gmagick-1.1.0-0.2.RC2.el6

Comment 6 Fedora Update System 2012-03-10 13:46:24 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/php-pecl-gmagick-1.1.0-0.2.RC2.fc15

Comment 7 Fedora Update System 2012-03-10 13:46:59 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/php-pecl-gmagick-1.1.0-0.2.RC2.fc16

Comment 8 Fedora Update System 2012-03-10 13:46:59 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/php-pecl-gmagick-1.1.0-0.2.RC2.fc17

Comment 9 Fedora Update System 2012-03-10 16:15:16 UTC
Package php-pecl-gmagick-1.1.0-0.2.RC2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-pecl-gmagick-1.1.0-0.2.RC2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3531/php-pecl-gmagick-1.1.0-0.2.RC2.fc17
then log in and leave karma (feedback).

Comment 10 Jan ONDREJ 2012-03-14 09:48:58 UTC
Created attachment 569943 [details]
Problematic image

Better, but still fails with segmentation fault. My testing image is attached.

Versions:
GraphicsMagick-1.3.14-1.el6.x86_64
php-pecl-gmagick-1.1.0-0.2.RC2.el6.x86_64

Testing script:
<?php

$image = new Gmagick();
$svg = file_get_contents('image.svg');
$image->readImageBlob($svg);
$image->write('image.jpg');
echo get_class($image). PHP_EOL;
exit;

How to reproduce:
# php test.php 
Gmagick
Segmentation fault

With C or en_US locale does not fail.

Curious, that this does not fail always, aprox. 2-3/10 times it's OK.

Comment 11 Pavel Alexeev 2012-03-16 19:03:57 UTC
Please provide stacktrace.

Comment 12 Rex Dieter 2012-03-16 19:35:01 UTC
Could very well be that the crash in comment #10 is something different too (we have no backtrace or evidence yet either way).

Comment 13 Rex Dieter 2012-03-16 19:38:07 UTC
oops, didn't mean to clear needinfo flag... resetting

Comment 14 Jan ONDREJ 2012-03-17 20:37:52 UTC
I can't give you backtrace, because I can't find debuginfo package for my current glibc for centos. If needed, I can give you my core file.
My glibc: glibc-2.12-1.47.el6_2.9.x86_64

Comment 15 Rex Dieter 2012-03-17 23:48:36 UTC
you don't need glibc-debuginfo, only GraphicsMagic-debuginfo, php-pecl-gmagick-debuginfo, php-debuginfo would likely be enough in this case.

Comment 16 Pavel Alexeev 2012-03-18 05:58:54 UTC
Yes, Rex is right, I hope glibc there irrelevant.

Comment 17 Jan ONDREJ 2012-03-18 06:21:48 UTC
Created attachment 570865 [details]
GDB output

Well, here is my backtrace:

(gdb) bt
#0  0x00007fffe95d46d2 in ?? ()
#1  0x00007fffe95d3046 in ?? ()
#2  0x00007fffe2694700 in ?? ()
#3  0x0000000000000000 in ?? ()

Full gdb command output attached.
I think it's useless. All required and available debuginfo packages have been installed.

Comment 18 Fedora Update System 2012-03-19 03:24:06 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2012-03-19 03:24:20 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Pavel Alexeev 2012-03-25 09:27:46 UTC
What is very interesting - I can reproduce it without GDB on test machine, but it does not segfaulted under GDB. I still can't understand why.

Could you please send me your coredump file?

Comment 21 Fedora Update System 2012-03-25 22:27:23 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2012-03-25 22:27:54 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Pavel Alexeev 2012-03-26 16:24:52 UTC
Reported upstream:
https://bugs.php.net/bug.php?id=61514

Comment 24 Jan ONDREJ 2012-03-30 05:49:09 UTC
Should I still put my core file here or open a new bug?

Comment 25 Rex Dieter 2012-03-31 01:36:53 UTC
I'd say a new bug (unless you find evidence that it is indeed the same issue)

Comment 26 Jan ONDREJ 2012-03-31 07:33:54 UTC
OK, new bug here: https://bugzilla.redhat.com/show_bug.cgi?id=808674

Comment 27 Pavel Alexeev 2012-04-01 16:11:26 UTC
*** Bug 808674 has been marked as a duplicate of this bug. ***

Comment 28 Pavel Alexeev 2012-04-01 16:18:42 UTC
If that the same, do not need open new bugs or post bugtrace. It is reported upstream and unfortunately I do not known how I can help more.

If you unsure that the same - attach it there please.

Comment 29 Jan ONDREJ 2012-04-01 16:24:39 UTC
I think it's not same, just it's introduced by version built here.
You can download core file from bug #808674, I will not attach another MB to RHBZ.

Comment 30 Pavel Alexeev 2012-04-08 07:38:29 UTC
Could you please show backtrace?

Comment 31 Jan ONDREJ 2012-04-10 08:43:57 UTC
(In reply to comment #30)
> Could you please show backtrace?

Who? Me? My backtrace is in comment #17.

Comment 32 Pavel Alexeev 2012-04-10 14:46:55 UTC
I hope it will be fixed upstream shortly.

Comment 33 Fedora Update System 2012-04-12 03:15:48 UTC
php-pecl-gmagick-1.1.0-0.2.RC2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.