Bug 751648 - Error reading path names with dots
Error reading path names with dots
Status: CLOSED DUPLICATE of bug 756617
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.4
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-11-06 20:30 EST by Manuel Ospina
Modified: 2015-11-09 19:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 23:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Manuel Ospina 2011-11-06 20:30:55 EST
Description of problem:
When pushing a file with a path that contains dots, the zanata python client is pushing it to the wrong place. 

Pushing the content of [...]/Installation_Guide/pot/topics/References/RHEV/2.3/Manager_Firewall_Requirements.pot to server:
Successfully updated template topics/References/RHEV/2 on the server


Version-Release number of selected component (if applicable):
zanata-python-client-1.3.1-1.fc14.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create POT files in which part of the path contains a dot
2. Push it to the server
3. Check the server
  
Actual results:
The client is sending the file to: topics/References/RHEV/2


Expected results:
The client should send the file to: topics/References/RHEV/2.3/Manager_Firewall_Requirements

Additional info:
Comment 1 James Ni 2011-11-28 21:02:56 EST
Hi, 

I have modified source code and push change 74e749a to git-hub to fix this issue,
please use that commit to verify it. please also reference bug 756617. thanks
Comment 2 Ding-Yi Chen 2012-02-21 23:25:45 EST

*** This bug has been marked as a duplicate of bug 756617 ***

Note You need to log in before you can comment on or make changes to this bug.