Bug 756617 - python client process file name not correctly for file name contain more than one dot
python client process file name not correctly for file name contain more than...
Status: CLOSED NEXTRELEASE
Product: Zanata
Classification: Community
Component: Component-PythonClient (Show other bugs)
1.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Ni
Ding-Yi Chen
:
: 751648 (view as bug list)
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-11-23 21:53 EST by James Ni
Modified: 2012-04-05 02:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.3.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 02:42:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Ni 2011-11-23 21:53:29 EST
Description of problem:

When i test Red_Hat_Enterprise_Linux/Release_Notes/trunk/6.2, I notice that python client has a issue with pot file named 6.2_Release_Notes.pot. After pushing to server, I look through the project on zanata server, i found that the file name changed to 6. Then, i check the source code, i found that i split the file name with dot and presume that first part is the file name and rest part is the suffix of the file name. But for pot file 6.2_Release_Notes.pot, this processing is definitive wrong.
Comment 1 James Ni 2011-11-23 21:59:21 EST
I have commit a change 74e749a to git-hub to fix this issue, please use that commit to verify it.
Comment 2 Ding-Yi Chen 2012-02-21 23:25:45 EST
*** Bug 751648 has been marked as a duplicate of this bug. ***
Comment 3 Ding-Yi Chen 2012-02-22 20:34:48 EST
VERIFIED with 1.3.4

Note You need to log in before you can comment on or make changes to this bug.