Bug 75174 - Installer does not provide upgrade option when booting off CD
Installer does not provide upgrade option when booting off CD
Status: CLOSED DUPLICATE of bug 72760
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-04 23:32 EDT by Brian Marsden
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 12:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Marsden 2002-10-04 23:32:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Boot off the CD (no options specified). Anaconda starts and we select region,
keyboard, mouse e.t.c.. Get to screen asking what sort of install/upgrade to do.
No Upgrade option shown (system is a 7.3 laptop). Try clicking on Personal
(Install) and click Next. Icons e.t.c. grayed out and does not go any further.
Clicking on Install ungrays the icons. Can't get any further than this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
As in description


Actual Results:  Upgrade not possible

Expected Results:  Wish to Upgrade from 7.3 to 8.0

Additional info:
Comment 1 Tom Sightler 2002-10-07 10:57:25 EDT
We ran into this exact same problem when attempting to upgrade a Dell Latitude
C600 that was running 7.3 as well.  We were eventually able to get around as
follows:

1. Select the Custom install options and click the next button.
2. When the options are greyed out, press Alt-N
3. The machine will then proceede to the upgrade screen.

It's almost like the installer is popping up another message asking if you want
to upgrade, however, there is no message on the screen.  It didn't seem to have
this problem on my laptop (a Dell Latitude C810).

Maybe this will help you.
Comment 2 Brian Marsden 2002-10-07 11:59:56 EDT
This is helpful. Thanks.

Note that, in the end, I upgraded using the text-only mode which showed the
upgrade option fine. The upgrade was smooth and without incident.
Comment 3 Jeremy Katz 2002-10-07 16:10:39 EDT
Note that the workaround is to boot with 'linux resolution=1024x768' or whatever
the native resolution of your LCD is.  Unfortunately, the driver seems to try to
be smarter than the user and falls back to another resolution without any real
way to pass this on.  this then breaks our font size settings.

*** This bug has been marked as a duplicate of 72760 ***

Note You need to log in before you can comment on or make changes to this bug.