Bug 75175 - terminfo 'linux' is incorrect in RH 8.0
terminfo 'linux' is incorrect in RH 8.0
Status: CLOSED DUPLICATE of bug 77585
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Eido Inoue
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 00:44 EDT by Need Real Name
Modified: 2006-02-21 13:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-05 00:44:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
When running 'make menuconfig' from the source directory (/usr/src/linux-2.4), 
the display is not set for the correct terminal. Running EXPORT shows 
TERM=linux. I took a RH Linux 7.3 machine, copied the terminfo file 'linux' to 
the new machine as linux-old, set the TERM varible to linux-old, and re-ran 
the 'make menuconfig' and everything looked correct. Something is definitely 
messed up in the new terminfo file 'linux'.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run 'make menuconfig'

	

Actual Results:  Garbled text output to the console.

Expected Results:  Correct text output, allowing my geeky self to fine tune 
kernel options.

Additional info:

I tried this on two different machines, one with an NVidia card and one with an 
OLD SiS card (to make sure that it isn't something weird with the AGP driver, 
or frame buffer). Both produced the same results on a stock RH 8.0 install.
Comment 1 Thomas E. Dickey 2003-01-12 12:58:32 EST
This would require using the wide-character ncursesw library.  (I just spent a couple of minutes to tweak the lxdialog makefile to use it).
Comment 2 Eido Inoue 2003-01-22 02:27:31 EST
wide-character ncursesw provided with ncurses-5.3-1

*** This bug has been marked as a duplicate of 77585 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.