Bug 77585 - Build wide-curses library.
Build wide-curses library.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Eido Inoue
Jay Turner
:
: 68199 70931 73422 75175 80806 81085 81769 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-09 15:15 EST by Sam Varshavchik
Modified: 2015-01-07 19:01 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-23 10:26:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to ncurses spec to enable widec includes + libraries (3.57 KB, patch)
2003-05-28 15:26 EDT, Tom "spot" Callaway
no flags Details | Diff
fixed version of original patch (3.68 KB, patch)
2003-05-28 15:35 EDT, Tom "spot" Callaway
no flags Details | Diff

  None (edit)
Description Sam Varshavchik 2002-11-09 15:15:13 EST
Description of Problem:

Psyche defaults to UTF-8 locale, which is not supported by lincurses.

Adding --enable-widec to the configure script builds a second library that uses
wide characters, lincursesw, which supports UTF-8.

I note that the current package does install the man pages for the
wide-character libncursesw, even though the actual library is not installed.
Comment 1 Thomas E. Dickey 2003-01-12 12:56:29 EST
My current best advice for this is to use ncurses 5.3 with the rollup patch at ftp://invisible-island.net/ncurses/5.3 - that incorporates fixes which I made to display line-drawing characters for Linux console and screen with UTF-8 locales.
Comment 2 Eido Inoue 2003-01-20 16:23:02 EST
5.3 should be in the next release
Comment 3 Eido Inoue 2003-01-20 16:24:08 EST
*** Bug 81769 has been marked as a duplicate of this bug. ***
Comment 4 Eido Inoue 2003-01-20 16:25:32 EST
*** Bug 73422 has been marked as a duplicate of this bug. ***
Comment 5 Eido Inoue 2003-01-20 16:31:59 EST
*** Bug 80806 has been marked as a duplicate of this bug. ***
Comment 6 Eido Inoue 2003-01-20 16:33:01 EST
*** Bug 70931 has been marked as a duplicate of this bug. ***
Comment 7 Eido Inoue 2003-01-20 16:49:56 EST
*** Bug 68199 has been marked as a duplicate of this bug. ***
Comment 8 Eido Inoue 2003-01-22 02:18:59 EST
fixed in ncurses-5.3-1
Comment 9 Eido Inoue 2003-01-22 02:19:53 EST
*** Bug 81085 has been marked as a duplicate of this bug. ***
Comment 10 Eido Inoue 2003-01-22 02:27:42 EST
*** Bug 75175 has been marked as a duplicate of this bug. ***
Comment 11 Steve Taylor 2003-01-30 16:24:52 EST
This is still very broken.... As a matter of fact it took a program that uses
ncurses that was ugly and made it totally unreadable :)
Comment 12 Thomas E. Dickey 2003-01-30 17:00:19 EST
what was the program (and the terminal description of course)?  I haven't seen
the RPM file in question, so I'll have to assume it's based on the rollup
patch, which works well enough for me on 8.0 (using an incorrect $TERM such
as "vt100" on the console will only make things worse ;-)
Comment 13 Eido Inoue 2003-01-31 15:28:29 EST
Please try 5.3-3, which adds the redhat version of xterm to the terminfo.src.
Comment 14 Steve Taylor 2003-02-03 11:35:00 EST
Just grabbed the latest one and its equally as bad. Not even a single character
is legible.
Comment 15 Eido Inoue 2003-02-03 15:10:56 EST
looking superficially at the program, i see that it dymanically links to both
termcap AND ncurses, which is not a good thing and will not survive upgrades.
You should use one or the other to guarantee your application will survive lib
upgrades.

the app in question seems to rely on a particular version of ncurses not being
upset with it's custom screen management.

the quick fix for the app vendor is to have their application statically link
with the termcap and ncurses combination that they test against. backwards
compatibility with their non-standard combo usage of ncurses/termcap
unfortunately cannot be guaranteed without breaking everything else as we move
forward with i18n.
Comment 16 pasquale annunziata 2003-02-19 02:33:33 EST
Description of your problem:

There is a differences in terminfo database for console 
(/usr/share/terminfo/l/linux) for capability setb setf and sgr because for our 
customer that use RM-CObol-85 not work properly  programs when display colors.
Not draw graphic lines.
This problems not exist with release of redhat linux 7.1 and 7.2.
What is changed between this release ?
Particulary not work high intensity that in coincidence between foreground and 
background display yellow color.
We have also installed ncurses 5.3 and the problem is the same.
Thanks. Resolution of this problem to make easy to resell RedHat products.
ing. P.Annunziata   Delta Sistemi srl

Our latest response:

Re: ticket update

Dear Sir,

Its best that you update the bug report 77585 so that our developers could 
address this issue directly to you.

http://bugzilla.redhat.com/bugzilla

Regards,
Michael
Comment 17 Thomas E. Dickey 2003-02-19 04:39:59 EST
I'm afraid this one sounds like a Redhat issue which
I've read about:  Redhat disabled the bold attribute,
to make a font "work" on the console.  It's not a
problem with ncurses or the terminfo description.
Comment 18 Thomas E. Dickey 2003-02-26 06:35:46 EST
I'm curious why this is marked closed, since it was not
fixed.
Comment 19 pasquale annunziata 2003-03-07 13:55:22 EST
I'm waiting solution of this problem. I hope to have explained well.
Thanks.
Best regards.
Pasquale Annunziata.
Comment 20 acount closed by user 2003-03-07 14:20:01 EST
rawhide ncurses-5.3-4.src.rpm has the patch to solve this bug:

--cortamorena--
* Thu Feb 06 2003 Bill Nottingham <notting@redhat.com> 5.3-4

- fix debuginfo package

* Fri Jan 31 2003 Adrian Havill <havill@redhat.com> 5.3-3

- remunged xterm changes from 5.2 patch for 5.3
- updated screen entry (#82951)
- fixed ka3, kb2 and kf0 entries (#77506)

* Wed Jan 22 2003 Tim Powers <timp@redhat.com>

- rebuilt

* Wed Jan 22 2003 Adrian Havill <havill@redhat.com> 5.3-1

- upgrade to 5.3 for sake of utf-8, wide chars (#77585 ...)
- spec file summary/desc grammar (#73583)
- add Requires: for c++ devel subpkg (#74002)
- terminfo.src patches no longer needed
- adjust autoconf patch
--end--
Comment 21 Sam Varshavchik 2003-03-07 17:51:22 EST
Technically, rawhide does NOT fix *this* bug.  The only way to support UTF-8 in
ncurses is to build lincursesw.so, using --enable-widec to configure.

Only the wide version of ncurses, that internally uses Unicode, will handle
UTF-8 properly.  The standard version of curses will think that each UTF-8 octet
occupies a separate character cell, and is completely ignored of double-wide
simplified/traditional Chinese characters.

libncursesw.so naturally uses a completely different ABI, so this bug should
probably be deferred until such time the ncurses package is actually flipped
into wide-character mode, and everything else is recompiled against it...

Comment 22 Thomas E. Dickey 2003-03-07 18:08:44 EST
There won't be (is no technical reason for) an ABI change: libncurses and libncursesw co-exist.
See for example, Debian, which is doing this.
Comment 23 Tom "spot" Callaway 2003-05-28 13:57:48 EDT
Reconsider adding the widec libs for a future release?
Comment 24 Tom "spot" Callaway 2003-05-28 15:26:40 EDT
Created attachment 92036 [details]
Patch to ncurses spec to enable widec includes + libraries

This is a patch to the ncurses 5.3-4 spec to build widec enabled includes and
libraries without affecting the "narrow" includes and libraries. No source code
changes need to be made to ncurses for this to work, and it will not break
compatibility with pre-existant ncurses dependent applications. 

By enabling widec includes and libraries, we open the door to applications like
cone, and continue supporting UTF-8.
Comment 25 Tom "spot" Callaway 2003-05-28 15:35:58 EDT
Created attachment 92038 [details]
fixed version of original patch

This patch keeps %configure instead of using ../configure. Thanks to Jeremy
Katz for pointing this out.
Comment 26 Thomas E. Dickey 2003-05-28 15:51:20 EDT
As I read the attachment, it says it uses the 20021231 rollup
patch.  Currently, the 20030510 rollup + 20030517 weekly
patch are the best solution (it fixes a bug in Linux console
for wide-character library when UTF-8 is disabled).
Comment 27 Eido Inoue 2003-05-28 15:59:23 EDT
thanks for the patch. I'm still cleaning up ncurses spec (it will include the
0517 patch, as this includes many UTF-8 wide fixes). it will have --enable-widec.

Note that apps will still have to be rebuilt to link against the "w" libraries
(which I'm doing for the obvious ones)
Comment 28 Sam Varshavchik 2003-06-22 00:30:01 EDT
ncurses 5.3-5 from Rawhide still isn't there yet.  It only installs the include
files for the narrowchar version of curses.  When you use --enable-widec, the
resulting include files are different than without --enable-widec.

For example, only the --enable-widec-built ncurses.h declares mvaddwstr(). 
Widechar applications still cannot be built against ncurses 5.3-5, they need the
widechar version of the include files, which are not installed.

Comment 29 Eido Inoue 2003-06-23 10:26:19 EDT
Try looking now (I don't control how/when Rawhide syncs up with internal data, btw).

Note You need to log in before you can comment on or make changes to this bug.