Bug 75182 - Missing font dependencies
Summary: Missing font dependencies
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 06:17 UTC by Douglas Kilpatrick
Modified: 2015-01-08 00:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-21 04:53:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Douglas Kilpatrick 2002-10-05 06:17:15 UTC
Description of Problem: 
 
Install up2date-gnome without installing various font packages and 
up2date fails to run due to missing fonts. 
 
Version-Release number of selected component (if applicable): 
[root@foo rhn]# rpm -q up2date-gnome up2date rhnlib gtk+ pygtk2-libglade 
gnome-python2 
up2date-gnome-3.0.7-1 
up2date-3.0.7-1 
rhnlib-1.0-1 
gtk+-1.2.10-22 
pygtk2-libglade-1.99.12-7 
gnome-python2-1.99.11-8 
 
 
How Reproducible: 
Very 
 
Steps to Reproduce: 
1. Server install, no X. 
2. Install up2date-gnome and the minimum packages to get it to install. 
3. run up2date with DISPLAY set to a good X server 
 
Actual Results: 
Loads of error messages about missing fonts and null fontsets. 
 
Expected Results: 
up2date window. 
 
Additional Information:

Comment 1 Adrian Likins 2002-10-18 21:23:59 UTC
Could you include an attachement showing the error messages?

It seems to work okay for me here, so I'm wondering which
fonts it cant find. 

If it is looking for X server side fonts, it may be an issue
with the Xserver you are using (and/or it's font config).



Comment 2 Alex Yu 2002-12-05 02:40:14 UTC
I guess I have similar problem.  I am using X-Win on Windows XP.  I try 
forward up2date to my desktop and the font looks very very small.

Comment 3 Adrian Likins 2003-01-21 04:53:02 UTC
Since up2date doesn't use any fonts that are not standard,
and I can't reproduce this, I'm putting this into
WORKSFORME.

Comment 4 Max Kanat-Alexander 2003-10-17 13:27:36 UTC
I reproduced this on today's (16-Oct-2003) rawhide release. It's virtually
identical to the real old bug 40072.

Could the problem be that I don't have the 75 dpi fonts installed, only the 100
dpi fonts?

Here's what I get (in my .xsession-errors) upon starting up2date-4.1.7-1:

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1183, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 845, in main
    gui.main()
  File "/usr/share/rhn/up2date_client/gui.py", line 2197, in main
    gui = Gui()
  File "/usr/share/rhn/up2date_client/gui.py", line 284, in __init__
    style.font = gtk.load_font("-*-helvetica-bold-r-normal--12-*-*-*-p-*-iso8859-1")

I actually don't have that font installed.

Here's the output of (xlsfonts | grep "helvetica-bold-r-normal--12"):

-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-2
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-2
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-r
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-r
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-u
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-u
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-ub
-adobe-helvetica-bold-r-normal--12-120-75-75-p-70-koi8-ub

Looking through my fonts, it seems that I have an 8859-1 font for every size
_except_ 12.

I have XFree86-4.3.0-40 and all related packages (excepting the 75dpi fonts).

-M


Note You need to log in before you can comment on or make changes to this bug.