Bug 752063 - Obscure Error message about missing BIOS boot partition in partitioning
Summary: Obscure Error message about missing BIOS boot partition in partitioning
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Keywords: CommonBugs
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-08 13:28 UTC by Petr Schindler
Modified: 2014-01-28 00:00 UTC (History)
14 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-02-13 14:01:16 UTC


Attachments (Terms of Use)

Description Petr Schindler 2011-11-08 13:28:47 UTC
Description of problem:
Obscure error message is shown when you try to create a new partition layout and don't create BIOS boot partition. It says "you have not created a bootloader stage1 target device" (screenshot is attached below). I thing that this message doesn't say anything about what to do to amend it and for many users it could be very confusing.

Version-Release number of selected component (if applicable):
anaconda-16.25

How reproducible:
always

Steps to Reproduce:
1. Run installation on machine with empty disk.
2. In partitioning dialog chose 'Create custom layout'
3. Create some layout without BIOS boot partition.
4. Click on 'next'
  
Actual results:
Error message 'you have not created a bootloader stage1 target device' is shown.

Expected results:
Message should be more describing

Additional info:
To avoid this error you have to create partition 1 or 2 MB large with file system 'BIOS boot'.

Comment 1 Nick 2011-11-20 20:39:04 UTC
I had this problem on a Dell Latitude E6400.  I was trying to install Fedora 16 x86_64 at the time using a DVD.  Creating a BIOS Boot partition in the installer did NOT help in this case.  (It did with an old Dell Optiplex 320 I was installing on.) 

As it turns out, that laptop has an EFI bootloader.  When you select boot methods, it has Legacy and EFI mode.  When I selected EFI mode, I Got this particular issue and was simply unable to continue regardless of my partition layout.  When I rebooted and booted via legacy, this problem disappeared completely. 

So for those of you unable to work around this issue using Anaconda and the partitioning tool, try a non EFI boot mode (if you have one available to you) and see if that helps.

Comment 2 Panos Kavalagios 2012-01-17 13:10:42 UTC
A walkaround tested on VirtualBox to avoid creating a dummy BIOS boot partition:

1. Press ctrl-alt-F2 or Host key-F2 in VirtualBox
2. Access the shell and run "fdisk /dev/sda"
3. Manually partition according to your desire the disk
4. Return back to graphical installer by pressing alt-F6
5. Press the "Reset" button
6. In the new layout loaded, assign ext4 and swap partitions for formatting
7. Press the "Next" button and continue the installation

Comment 3 Foampile 2012-01-20 07:48:57 UTC
Here are some related threads, I am having the same issue.  Tried EVERYTHING, no help:

https://bugzilla.redhat.com/show_bug.cgi?id=755226

http://forums.fedoraforum.org/showthread.php?p=1548003

thanks

Comment 4 Gerrit Slomma 2012-04-30 12:22:36 UTC
Got the same error when trying to install Fedora 16 in a QEMU/KVM-virtual machine.
What is the root-cause of that ominous error in the first place? EFI-type BIOS? Since installation of RHEL/SL 6.x is working without a 2 MB bios-boot partition.
And could the error message be reworded to give a hint what is realy expected by the installation procedure? The localized version(s) of this error are a bit more off to make things worse, in German it goes like this: "Sie haben kein Zielgerät für Bootloader Stage 1 eingerichtet", but none such device exists, there is a "Filesystem type" or "Dateisystemtyp" "BIOS Boot" however. Another problem arises if i specify a "BIOS boot" filesystem with a "Size (MB)" of 2 and either "Fixed Size" or "Fill up entire space up to (MB): 2", i everytime get the error message "requested partitions could not be assigned: "partition is too large for BIOS boot formating (allowable size is 0 MB to 2 MB)." The same applies if i enter 1 as size. Entering 0 resets the field to 1 MB. So i can't get it to install.

Comment 5 Gerrit Slomma 2012-04-30 12:24:27 UTC
Oh, went back and fort one time an retried to create the "BIOS boot" filesystem with a size of 1 MB, worked now.

Comment 6 reescf 2012-09-11 21:01:15 UTC
I got this error trying to install Fedora 17 on a machine with UEFI and EFI boot enabled in BIOS. It would not let me continue even though I had an EFI partition marked as such prepared. In the end, I went with BIOS boot but whatever the installer then did left the machine unbootable except via the BIOS boot menu. I finally corrected the mess by hand but I still don't really understand what the installer did. On straight boot, I would get a grub rescue shell but via the BIOS boot menu, I could boot via grub menu.

Comment 7 Andrew Haley 2012-11-22 15:41:54 UTC
It seems to be related to UEFI booting. The only thing I could do to get past this point is to go into the BIOS and select BIOS Legacy boot mode only.

Comment 8 Fedora End Of Life 2013-01-16 13:17:45 UTC
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 9 Fedora End Of Life 2013-02-13 14:01:20 UTC
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 10 nbeier 2013-09-07 16:13:13 UTC
On Fedora 19 (LXDE spin), Anaconda blocks installation with the error message
"you have not created a bootloader stage1 target device"
in the cases where custom partitioning AND "Do not install bootloader" is chosen together with a DOS partition table and Partition scheme set to "Standard partition".

If Anaconda can not handle installation without a dedicated /boot partition, on systems where it is not required (plain BIOS, no RAID/LVM/GPT etc.), it should inform the user directly. (Reading the documentation at https://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/s2-diskpartrecommend-x86.html  does not give the impression that a /boot mount partition is always required.)

If the rest of Fedora installation CAN handle having /boot on the / root partition, Anaconda is blocking the installation for no good reason, in some cases

The error given is badly worded, and seems not to be rephrased up to now, in Fedora 19.

Comment 11 Adam Williamson 2014-01-27 23:53:33 UTC
"in the cases where custom partitioning AND "Do not install bootloader" is chosen"

are you *sure* you disabled bootloader installation? Because I'm looking at that check right now, and it says:

        if self.bootloader and not self.bootloader.skip_bootloader:
            (perform the check)

i.e., the check seems pretty clearly to be skipped if 'bootloader.skip_bootloader' is set.

Comment 12 Adam Williamson 2014-01-28 00:00:50 UTC
Just tested with current F21 anaconda, I can disable bootloader installation and create a custom layout with just swap and / on an msdos labelled disk, and it works fine.


Note You need to log in before you can comment on or make changes to this bug.