Bug 75226 - inserting audio cd and then hitting play button does not play audio cd
inserting audio cd and then hitting play button does not play audio cd
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Jay Turner
: Triaged
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
 
Reported: 2002-10-05 13:23 EDT by Yusuf Goolamabbas
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-09 08:53:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yusuf Goolamabbas 2002-10-05 13:23:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020922

Description of problem:
When one inserts an audio cd into the tray, the gnome-cd application pops up,
after looking up track information via CDDB/freedb, it presents you with the
first track of the CD. When you hit the play button, nothing happens till you
click on the little CD icon in the display area which switches to a music symbol
Then you can hit play and the CD will play that track
After playing the track, the next track won't be played and the application will
revert back to the beggining of the last (ie first) track played


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Insert audio cd into tray
2. Wait till CDDB info is acquired 
3. Press the Play button
4. Nothing happens
5. Click on CD icon in display area (next to the little red arrow)
6. Switches to a music symbol (like a note)
7. Then press play button and voila the CD plays
8. It seems to only play one track though. No way to tell it to play
   all tracks	

Additional info:
Comment 1 Havoc Pennington 2002-10-05 13:58:24 EDT
The little CD icon goes between whole-CD mode (the CD) and single-track mode
(the note). However I admit I had to read the source code to figure that out. ;-)

I don't know why it won't play in whole-CD mode on your system, I'm assuming it
works for most people as we don't have other reports. Are there any errors
on stderr? (~/.xsession-errors)
Comment 2 Yusuf Goolamabbas 2002-10-05 21:11:27 EDT
Havoc, This is what I see in /var/log/messages after I place an audio-cd in the
track and click the play button a few times


Oct  6 09:01:57 cm61-10-94-231 kernel: sr0: CDROM (ioctl) reports ILLEGAL REQUES
T.
Oct  6 09:02:51 cm61-10-94-231 last message repeated 5 times
Oct  6 09:06:03 cm61-10-94-231 last message repeated 3 times

My CDROM is a RICOH MP7320A. It used to play CD's perfectly before with RH
7.3/Ximian desktop. I did a fresh reinstall on this box and formatted all the
partitions
Comment 3 Havoc Pennington 2002-10-05 23:38:51 EDT
are those messages definitely from pressing play (they appear as you click play,
and don't appear otherwise?)
Comment 4 Yusuf Goolamabbas 2002-10-06 05:14:47 EDT
Yes, the ioctl messages only occurs when I press the Play button when the CD
icon is displayed in the display area

This is what I did

I removed /var/log/messages and restarted syslog therby creating a new
/var/log/messages file

I inserted an audio-cd into the CD tray and saw the following message in
/var/log/messages. I had configured gnome-cd to start playing the audio CD when
it starts

Oct  6 17:06:41 cm61-10-94-231 kernel: sr0: CDROM (ioctl) reports ILLEGAL REQUES
T.

Then I configured gnome-cd to do nothing when gnome-cd starts. I stopped and
restarted gnome-cd and pressed the play button

Oct  6 17:07:29 cm61-10-94-231 kernel: sr0: CDROM (ioctl) reports ILLEGAL REQUES
T.

Then a minute later, I pressed play again
Oct  6 17:09:20 cm61-10-94-231 kernel: sr0: CDROM (ioctl) reports ILLEGAL REQUES
T.

I don't see any messages if the CD icon is switched to the note icon and I press
the play button subsequently

Hope this helps
Comment 5 Havoc Pennington 2002-10-06 12:27:26 EDT
Can you try another CD application, such as koncd, or I think "cdplay" on the
command line, and see if those work? (I'm trying to see if this is a driver issue 
or gnome-cd being confused.)
Comment 6 Yusuf Goolamabbas 2002-10-06 18:58:13 EDT
havoc, I tried 'cdp' (cdplay is the non-interactive version).
It works perfectly. Starts playing the first track when I launch cdp and
continues to move forward

Another data point, I have a SCSI hard-disk connected to an Adapatec controller
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.8
        <Adaptec 2940 Ultra2 SCSI adapter>
        aic7890/91: Ultra2 Wide Channel A, SCSI Id=7, 32/253 SCBs

blk: queue c2535814, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: SEAGATE   Model: ST318275LW        Rev: 0001
  Type:   Direct-Access                      ANSI SCSI revision: 02
blk: queue c2535a14, I/O limit 4095Mb (mask 0xffffffff)
scsi0:A:0:0: Tagged Queuing enabled.  Depth 253
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:A:0): 40.000MB/s transfers (20.000MHz, offset 15, 16bit)
SCSI device sda: 35566480 512-byte hdwr sectors (18210 MB)

Attached scsi CD-ROM sr0 at scsi1, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.12


Comment 7 Rui Miguel Seabra 2003-01-06 16:36:03 EST
I think that this bug is related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71887

Probably corrupt cd's? See my comments on the other one.
Comment 8 Dan Carpenter 2003-02-03 18:52:23 EST
I have the exact problem on 2 systems with RedHat 8.0 and CD-R/RW drives. 
Clicking on the CD icon can make the cd play.  The ILLEGAL REQUEST message in
dmesg is the same.  

I do not think that this bug is related to <a
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71887">#71887</a>  My
systems do not segment fault and I tried a couple CDs so I know the media is not
corrupt.

The problem seem to be related to CD-R/RW drives.

xmms, cdp and cdplay work.

On my system /dev/cdrom is a symlink to /dev/scd0.
Comment 9 Colin Walters 2004-09-27 14:56:09 EDT
Ok.  gnome-media has gone through a lot of new versions since then -
can anyone here still reproduce this probelm with Fedora Core 2?
Comment 10 Yusuf Goolamabbas 2004-10-09 08:53:08 EDT
Seems to work in Fedora Core 2. Though even though I don't have 'Start
playing CD when CD player starts' enabled the CD automatically plays
after acquiring CDDB information

Will look at this behaviour again in Fedora Core 3 

Note You need to log in before you can comment on or make changes to this bug.