Bug 75253 - ncftp cannot connect to server with IPv6 addresses
Summary: ncftp cannot connect to server with IPv6 addresses
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 74314 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-06 03:52 UTC by Ulrich Drepper
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 14:45:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Drepper 2002-10-06 03:52:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020812

Description of problem:
I don't know why but ncftp cannot connect to some sites.  I don't know what
differentiates them

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ncftpls ftp://nl.linux.org
2.
3.
	

Actual Results:  Could not get a socket: Address family not supported by protocol.
ncftpls: cannot open nl.linux.org: could not get a new stream socket.


Expected Results:  Listing of the FTP server.

Additional info:

The name lookup inside is most probably (ok, definitely) using getaddrinfo. On
servers which have IPv6 addresses they will be reported back first if the caller
is interested in either.  If now the ipv6 kernel module is not loaded the socket
calls will fail:


socket(PF_INET6, SOCK_STREAM, 0)        = -1 ENOSYS (Function not implemented)
socket(PF_INET6, SOCK_STREAM, 0)        = -1 ENOSYS (Function not implemented)
socket(PF_INET6, SOCK_STREAM, 0)        = -1 EAFNOSUPPORT (Address family not su


ncftp should not fail in this case unless there is no IPv4 address at all
returned.  This is not the case for nl.linux.org.

Comment 1 Need Real Name 2002-11-18 11:52:53 UTC
it seems fixed in ncftp 3.1.5

Comment 2 Pekka Savola 2003-07-22 10:56:38 UTC
*** Bug 74314 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.