Bug 752741 - authconfig --krb5realm... --update crashes (python backtrace)
authconfig --krb5realm... --update crashes (python backtrace)
Status: CLOSED DUPLICATE of bug 752495
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 05:03 EST by Jon Dowland
Modified: 2011-11-10 05:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-10 05:14:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kerberos krb5.conf file (572 bytes, application/octet-stream)
2011-11-10 05:03 EST, Jon Dowland
no flags Details

  None (edit)
Description Jon Dowland 2011-11-10 05:03:33 EST
Created attachment 532770 [details]
kerberos krb5.conf file

Description of problem:

Running authconfig results in a program crash and python traceback.

Version-Release number of selected component (if applicable):

Version     : 6.1.16
Release     : 1.fc16

How reproducible:

Always (for me).

Steps to Reproduce:
1. /usr/sbin/authconfig --krb5realm=CAMPUS.NCL.AC.UK --update
2. ...
3. profit!
  
Actual results:


Traceback (most recent call last):
  File "/usr/sbin/authconfig", line 938, in <module>
    sys.exit(module.run())
  File "/usr/sbin/authconfig", line 538, in run
    self.writeAuthInfo()
  File "/usr/sbin/authconfig", line 505, in writeAuthInfo
    if not self.info.writeChanged(self.pristineinfo):
  File "/usr/share/authconfig/authinfo.py", line 3632, in writeChanged
    ret = ret and group.saveFunction()
  File "/usr/share/authconfig/authinfo.py", line 2974, in writeSSSD
    self.sssdConfig.save_domain(domain)
  File "/usr/lib/python2.7/site-packages/SSSDConfig.py", line 1765, in save_domain
    self.delete_option_subtree(section_subtree, 'option', option['name'], True)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 559, in delete_option_subtree
    index, item = self.findOpts(subtree, type, name, exclude_sections)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 201, in findOpts
    if o['type'] == type and o['name'] == name:
TypeError: 'int' object is not subscriptable


Expected results:

No console output, successful return code; krb5.conf updated; a machine I can log into.

Additional info:

I've reproduced the above by hand,  but normally puppet is invoking authconfig for me.

"CAMPUS.NCL.AC.UK" is a pre-existing realm in my krb5.conf (which I will attach).
Comment 1 Tomas Mraz 2011-11-10 05:14:12 EST

*** This bug has been marked as a duplicate of bug 752495 ***

Note You need to log in before you can comment on or make changes to this bug.