This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 752495 - Crash when apply settings
Crash when apply settings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sssd (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
: 752741 (view as bug list)
Depends On:
Blocks: 768935
  Show dependency treegraph
 
Reported: 2011-11-09 12:19 EST by Bill C. Riemers
Modified: 2012-01-03 20:52 EST (History)
6 users (show)

See Also:
Fixed In Version: sssd-1.6.4-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 768935 (view as bug list)
Environment:
Last Closed: 2012-01-03 20:52:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/sssd/sssd.conf causing the error (2.28 KB, text/plain)
2011-11-09 18:17 EST, Bill C. Riemers
no flags Details

  None (edit)
Description Bill C. Riemers 2011-11-09 12:19:38 EST
Description of problem:

Whenever I click on the apply button, the dialog crashes, my settings are not saved.


Version-Release number of selected component (if applicable):

authconfig-gtk-6.1.16-1.fc16.x86_64

How reproducible:

100%

Steps to Reproduce:
1. system-config-gtk
2. set some parameters, such as an LDAP configuration
3. click apply
  
Actual results:

[root@briemersw sssd]# system-config-authentication 
Traceback (most recent call last):
  File "/usr/sbin/system-config-authentication", line 701, in <module>
    module.apply()
  File "/usr/sbin/system-config-authentication", line 650, in apply
    self.info.writeChanged(self.pristineinfo)
  File "/usr/share/authconfig/authinfo.py", line 3632, in writeChanged
    ret = ret and group.saveFunction()
  File "/usr/share/authconfig/authinfo.py", line 2974, in writeSSSD
    self.sssdConfig.save_domain(domain)
  File "/usr/lib/python2.7/site-packages/SSSDConfig.py", line 1765, in save_domain
    self.delete_option_subtree(section_subtree, 'option', option['name'], True)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 559, in delete_option_subtree
    index, item = self.findOpts(subtree, type, name, exclude_sections)
  File "/usr/lib/python2.7/site-packages/ipachangeconf.py", line 201, in findOpts
    if o['type'] == type and o['name'] == name:
TypeError: 'int' object is not subscriptable


Expected results:

savings are applied

Additional info:
Comment 1 Tomas Mraz 2011-11-09 17:17:43 EST
I cannot reproduce the problem on my freshly updated Fedora 16 VM. The traceback comes from the SSSD configuration API, reassigning.
Comment 2 Bill C. Riemers 2011-11-09 18:17:23 EST
Created attachment 532688 [details]
/etc/sssd/sssd.conf causing the error

It looks like the code that is reporting the error is designed to remove unrecognised options from the config file.   I do not know which option it is causing the problem.   Based on the idea that it works with a fresh install, I replaced this file with the fresh install file and reconfigured from scratch.
Comment 3 Tomas Mraz 2011-11-10 05:14:12 EST
*** Bug 752741 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Hrozek 2011-11-10 07:08:26 EST
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1082
Comment 5 Jon Dowland 2011-11-10 09:35:34 EST
In my case (merged bug 752741) this was a pristine F16 install and no custom sssd.conf.
Comment 6 Fedora Update System 2011-12-19 16:28:00 EST
sssd-1.6.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/sssd-1.6.4-1.fc16
Comment 7 Fedora Update System 2011-12-22 17:51:32 EST
Package sssd-1.6.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sssd-1.6.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17349/sssd-1.6.4-1.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-01-03 20:52:19 EST
sssd-1.6.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.